summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-06-07 14:36:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-06-07 14:36:12 +0000
commit496dc89e82230b5793a98cb6531bff6027f88902 (patch)
treea478696efd33b3fc7d30fad9d5cf4c111f24aafc /sys-apps
parentVersion bump (diff)
downloadgentoo-2-496dc89e82230b5793a98cb6531bff6027f88902.tar.gz
gentoo-2-496dc89e82230b5793a98cb6531bff6027f88902.tar.bz2
gentoo-2-496dc89e82230b5793a98cb6531bff6027f88902.zip
Version bump, adds compat with BSD and musl
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/elfix/ChangeLog7
-rw-r--r--sys-apps/elfix/elfix-0.8.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 004f597bb6a9..feccaa134c58 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/elfix
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/ChangeLog,v 1.82 2014/01/26 12:12:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/ChangeLog,v 1.83 2014/06/07 14:36:12 blueness Exp $
+
+*elfix-0.8.5 (07 Jun 2014)
+
+ 07 Jun 2014; Anthony G. Basile <blueness@gentoo.org> +elfix-0.8.5.ebuild:
+ Version bump, adds compat with BSD and musl
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> elfix-0.8.4.ebuild:
Stable for sparc, wrt bug #495624
diff --git a/sys-apps/elfix/elfix-0.8.5.ebuild b/sys-apps/elfix/elfix-0.8.5.ebuild
new file mode 100644
index 000000000000..dd459698fb2b
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.8.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.8.5.ebuild,v 1.1 2014/06/07 14:36:12 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}