summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-09-20 14:52:44 +0000
committerNed Ludd <solar@gentoo.org>2008-09-20 14:52:44 +0000
commit4f990f13c0cc2cd8d6b5d663f99728ee1d6b3564 (patch)
treef494706505931c13e6276e7367c0ae7e4761a929 /sys-apps
parentMass stablization for ppc and ppc64 for bug 237127 (diff)
downloadgentoo-2-4f990f13c0cc2cd8d6b5d663f99728ee1d6b3564.tar.gz
gentoo-2-4f990f13c0cc2cd8d6b5d663f99728ee1d6b3564.tar.bz2
gentoo-2-4f990f13c0cc2cd8d6b5d663f99728ee1d6b3564.zip
- keyword ~arm. fix cflags settings and make cross compile aware.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/netplug/ChangeLog9
-rw-r--r--sys-apps/netplug/netplug-1.2.9-r4.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/sys-apps/netplug/ChangeLog b/sys-apps/netplug/ChangeLog
index faf01e6925db..7956c4b81ee3 100644
--- a/sys-apps/netplug/ChangeLog
+++ b/sys-apps/netplug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/netplug
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/netplug/ChangeLog,v 1.14 2007/12/25 16:34:41 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netplug/ChangeLog,v 1.15 2008/09/20 14:52:44 solar Exp $
+
+*netplug-1.2.9-r4 (20 Sep 2008)
+
+ 20 Sep 2008; <solar@gentoo.org> +netplug-1.2.9-r4.ebuild:
+ - keyword ~arm. fix cflags settings and make cross compile aware.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing uberlord from metadata.xml as per #199318. Assigning to
diff --git a/sys-apps/netplug/netplug-1.2.9-r4.ebuild b/sys-apps/netplug/netplug-1.2.9-r4.ebuild
new file mode 100644
index 000000000000..7b8bd41ffbfd
--- /dev/null
+++ b/sys-apps/netplug/netplug-1.2.9-r4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netplug/netplug-1.2.9-r4.ebuild,v 1.1 2008/09/20 14:52:44 solar Exp $
+
+inherit eutils toolchain-funcs
+DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
+HOMEPAGE="http://www.red-bean.com/~bos/"
+SRC_URI="http://www.red-bean.com/~bos/netplug/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~arm"
+IUSE=""
+
+hax_bitkeeper() {
+ # the makefiles have support for bk ...
+ # basically we have to do this or bk will try to write
+ # to files in /opt/bitkeeper causing sandbox violations ;(
+ mkdir "${T}/fakebin"
+ echo "#!/bin/sh"$'\n'"exit 1" > "${T}/fakebin/bk"
+ chmod a+x "${T}/fakebin/bk"
+ export PATH="${T}/fakebin:${PATH}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove debugging from Makefile
+ # Remove -O3 if we have -O[0-9,s] in our CFLAGS
+ local remove=" -ggdb3 "
+ [[ " ${CFLAGS} " == *" -O"[0-9,s]" "* ]] && remove="${remove}-O3 "
+ sed -i -e "s/${remove}/ /" Makefile
+
+ # Use correct structure for getsockname arg 3
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+
+ # Remove nested functions, #116140
+ epatch "${FILESDIR}/${P}-remove-nest.patch"
+
+ # Ignore wireless events
+ epatch "${FILESDIR}/${P}-ignore-wireless.patch"
+}
+
+src_compile() {
+ tc-export CC
+ hax_bitkeeper
+ make CC="${CC}" || die "emake failed"
+}
+
+src_install() {
+ into /
+ dosbin netplugd
+ doman man/man8/netplugd.8
+
+ dodir /etc/netplug.d
+ exeinto /etc/netplug.d
+ doexe "${FILESDIR}/netplug"
+
+ dodir /etc/netplug
+ echo "eth*" > "${D}"/etc/netplug/netplugd.conf
+}