summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-06-30 07:45:44 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-06-30 07:45:44 +0000
commit5f4e504763dd787ec0adf93332e139db6b52c106 (patch)
tree1f25f62f11dbeb189a388dfb92ef8e8d35f3fdcb /sys-apps
parentVersion bump. Removed old (diff)
downloadgentoo-2-5f4e504763dd787ec0adf93332e139db6b52c106.tar.gz
gentoo-2-5f4e504763dd787ec0adf93332e139db6b52c106.tar.bz2
gentoo-2-5f4e504763dd787ec0adf93332e139db6b52c106.zip
Version bump. Removed old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute2/ChangeLog8
-rw-r--r--sys-apps/iproute2/iproute2-4.0.0.ebuild124
-rw-r--r--sys-apps/iproute2/iproute2-4.1.0.ebuild (renamed from sys-apps/iproute2/iproute2-4.0.0-r1.ebuild)13
3 files changed, 15 insertions, 130 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 5f277ce63b3e..afea5de3042e 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/iproute2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.263 2015/05/24 03:42:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.264 2015/06/30 07:45:44 polynomial-c Exp $
+
+*iproute2-4.1.0 (30 Jun 2015)
+
+ 30 Jun 2015; Lars Wendler <polynomial-c@gentoo.org> -iproute2-4.0.0.ebuild,
+ -iproute2-4.0.0-r1.ebuild, +iproute2-4.1.0.ebuild:
+ Version bump. Removed old.
24 May 2015; Mike Frysinger <vapier@gentoo.org> iproute2-4.0.0-r2.ebuild,
iproute2-9999.ebuild, metadata.xml:
diff --git a/sys-apps/iproute2/iproute2-4.0.0.ebuild b/sys-apps/iproute2/iproute2-4.0.0.ebuild
deleted file mode 100644
index 5ec4572ab966..000000000000
--- a/sys-apps/iproute2/iproute2-4.0.0.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-4.0.0.ebuild,v 1.1 2015/04/15 11:58:43 polynomial-c Exp $
-
-EAPI="5"
-
-inherit eutils toolchain-funcs flag-o-matic multilib
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
- inherit git-2
-else
- SRC_URI="mirror://kernel/linux/utils/net/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-DESCRIPTION="kernel routing and traffic control utilities"
-HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="atm berkdb +iptables ipv6 minimal selinux"
-
-RDEPEND="!net-misc/arpd
- iptables? ( >=net-firewall/iptables-1.4.20:= )
- !minimal? ( berkdb? ( sys-libs/db:= ) )
- atm? ( net-dialup/linux-atm )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- iptables? ( virtual/pkgconfig )
- sys-devel/bison
- sys-devel/flex
- >=sys-kernel/linux-headers-2.6.27
- elibc_glibc? ( >=sys-libs/glibc-2.7 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
- use ipv6 || epatch "${FILESDIR}"/${PN}-3.10.0-no-ipv6.patch #326849
-
- sed -i \
- -e '/^CC =/d' \
- -e "/^LIBDIR/s:=.*:=/$(get_libdir):" \
- -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
- -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
- -e "/^WFLAGS/s:-Werror::" \
- -e "/^DBM_INCLUDE/s:=.*:=${T}:" \
- Makefile || die
-
- # Use /run instead of /var/run.
- sed -i \
- -e 's:/var/run:/run:g' \
- ip/ipnetns.c \
- man/man8/ip-netns.8 || die
-
- # build against system headers
- rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
- sed -i 's:TCPI_OPT_ECN_SEEN:16:' misc/ss.c || die
-
- # don't build arpd if USE=-berkdb #81660
- use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
-
- use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc:' Makefile
-}
-
-src_configure() {
- tc-export AR CC PKG_CONFIG
-
- # This sure is ugly. Should probably move into toolchain-funcs at some point.
- local setns
- pushd "${T}" >/dev/null
- echo 'main(){return setns();};' > test.c
- ${CC} ${CFLAGS} ${LDFLAGS} test.c >&/dev/null && setns=y || setns=n
- echo 'main(){};' > test.c
- ${CC} ${CFLAGS} ${LDFLAGS} test.c -lresolv >&/dev/null || sed -i '/^LDLIBS/s:-lresolv::' "${S}"/Makefile
- popd >/dev/null
-
- cat <<-EOF > Config
- TC_CONFIG_ATM := $(usex atm y n)
- TC_CONFIG_XT := $(usex iptables y n)
- HAVE_SELINUX := $(usex selinux y n)
- IP_CONFIG_SETNS := ${setns}
- # Use correct iptables dir, #144265 #293709
- IPT_LIB_DIR := $(use iptables && ${PKG_CONFIG} xtables --variable=xtlibdir)
- EOF
-}
-
-src_install() {
- if use minimal ; then
- into /
- dosbin tc/tc
- return 0
- fi
-
- emake \
- DESTDIR="${D}" \
- LIBDIR="${EPREFIX}"/$(get_libdir) \
- SBINDIR="${EPREFIX}"/sbin \
- CONFDIR="${EPREFIX}"/etc/iproute2 \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
- MANDIR="${EPREFIX}"/usr/share/man \
- ARPDDIR="${EPREFIX}"/var/lib/arpd \
- install
-
- rm "${ED}"/usr/share/doc/${PF}/*.{sgml,tex} || die #455988
-
- dodir /bin
- mv "${ED}"/{s,}bin/ip || die #330115
-
- dolib.a lib/libnetlink.a
- insinto /usr/include
- doins include/libnetlink.h
- # This local header pulls in a lot of linux headers it
- # doesn't directly need. Delete this header that requires
- # linux-headers-3.8 until that goes stable. #467716
- sed -i '/linux\/netconf.h/d' "${ED}"/usr/include/libnetlink.h || die
-
- if use berkdb ; then
- dodir /var/lib/arpd
- # bug 47482, arpd doesn't need to be in /sbin
- dodir /usr/bin
- mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
- fi
-}
diff --git a/sys-apps/iproute2/iproute2-4.0.0-r1.ebuild b/sys-apps/iproute2/iproute2-4.1.0.ebuild
index 2df8d47bcfcf..1a99656ee3ec 100644
--- a/sys-apps/iproute2/iproute2-4.0.0-r1.ebuild
+++ b/sys-apps/iproute2/iproute2-4.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-4.0.0-r1.ebuild,v 1.1 2015/04/20 20:51:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-4.1.0.ebuild,v 1.1 2015/06/30 07:45:44 polynomial-c Exp $
EAPI="5"
@@ -23,20 +23,20 @@ IUSE="atm berkdb +iptables ipv6 minimal selinux"
RDEPEND="!net-misc/arpd
iptables? ( >=net-firewall/iptables-1.4.20:= )
- !minimal? ( berkdb? ( sys-libs/db:= ) )
+ berkdb? ( sys-libs/db:= )
atm? ( net-dialup/linux-atm )
selinux? ( sys-libs/libselinux )"
+# We require newer linux-headers for ipset support #549948
DEPEND="${RDEPEND}
app-arch/xz-utils
iptables? ( virtual/pkgconfig )
sys-devel/bison
sys-devel/flex
- >=sys-kernel/linux-headers-2.6.27
+ >=sys-kernel/linux-headers-3.7
elibc_glibc? ( >=sys-libs/glibc-2.7 )"
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
- epatch "${FILESDIR}"/${P}-tc-show-buffer-overflow.patch #546928
use ipv6 || epatch "${FILESDIR}"/${PN}-3.10.0-no-ipv6.patch #326849
sed -i \
@@ -61,7 +61,7 @@ src_prepare() {
# don't build arpd if USE=-berkdb #81660
use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
- use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc:' Makefile
+ use minimal && sed -i -e '/^SUBDIRS=/s:=.*:=lib tc ip:' Makefile
}
src_configure() {
@@ -79,6 +79,8 @@ src_configure() {
cat <<-EOF > Config
TC_CONFIG_ATM := $(usex atm y n)
TC_CONFIG_XT := $(usex iptables y n)
+ # We've locked in recent enough kernel headers #549948
+ TC_CONFIG_IPSET := y
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, #144265 #293709
@@ -90,6 +92,7 @@ src_install() {
if use minimal ; then
into /
dosbin tc/tc
+ dobin ip/ip
return 0
fi