summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2015-04-22 15:30:39 +0000
committerJustin Bronder <jsbronder@gentoo.org>2015-04-22 15:30:39 +0000
commit682e627f7d971bc68e12c6719221b0c1583afac0 (patch)
treefc121d7cbbf236695cb5f75d0047f68aa24ec7dd /sys-apps
parentCleanup. (diff)
downloadgentoo-2-682e627f7d971bc68e12c6719221b0c1583afac0.tar.gz
gentoo-2-682e627f7d971bc68e12c6719221b0c1583afac0.tar.bz2
gentoo-2-682e627f7d971bc68e12c6719221b0c1583afac0.zip
Backport upstream hwloc-gather-topology fix (6d42748). Resolves #547366
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/files/hwloc-gather-topology-fix-lstopo-path-after-install.patch26
-rw-r--r--sys-apps/hwloc/hwloc-1.10.0-r1.ebuild7
-rw-r--r--sys-apps/hwloc/hwloc-1.10.1.ebuild7
4 files changed, 43 insertions, 4 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index 21488d681107..cf1b9397e513 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.50 2015/02/20 15:26:40 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.51 2015/04/22 15:30:39 jsbronder Exp $
+
+ 22 Apr 2015; Justin Bronder <jsbronder@gentoo.org> hwloc-1.10.0-r1.ebuild,
+ hwloc-1.10.1.ebuild,
+ +files/hwloc-gather-topology-fix-lstopo-path-after-install.patch:
+ Backport upstream hwloc-gather-topology fix (6d42748). Resolves #547366
*hwloc-1.10.1 (20 Feb 2015)
diff --git a/sys-apps/hwloc/files/hwloc-gather-topology-fix-lstopo-path-after-install.patch b/sys-apps/hwloc/files/hwloc-gather-topology-fix-lstopo-path-after-install.patch
new file mode 100644
index 000000000000..f383b3ab3a7a
--- /dev/null
+++ b/sys-apps/hwloc/files/hwloc-gather-topology-fix-lstopo-path-after-install.patch
@@ -0,0 +1,26 @@
+From 6d42748f8604f3c1d0ca6cf122e8776b3c153ac4 Mon Sep 17 00:00:00 2001
+From: Brice Goglin <Brice.Goglin@inria.fr>
+Date: Thu, 12 Mar 2015 10:01:13 +0100
+Subject: [PATCH] hwloc-gather-topology: fix lstopo path after install
+
+Broken when utils moved to utils/ subdirectories.
+
+(cherry picked from commit 0a32f719c48fb7dabf4882f8f2477017c25b15a9)
+---
+ NEWS | 1 +
+ tests/linux/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/linux/Makefile.am b/tests/linux/Makefile.am
+index f0a2f8a..27c261a 100644
+--- a/tests/linux/Makefile.am
++++ b/tests/linux/Makefile.am
+@@ -171,7 +171,7 @@ LOG_COMPILER = $(builddir)/test-topology.sh
+ bin_SCRIPTS = hwloc-gather-topology
+
+ install-exec-hook:
+- $(SED) -e 's/HWLOC_top_builddir\/utils/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-gather-topology > $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp $(DESTDIR)$(bindir)/hwloc-gather-topology
++ $(SED) -e 's/HWLOC_top_builddir\/utils\/lstopo/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-gather-topology > $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-gather-topology.tmp $(DESTDIR)$(bindir)/hwloc-gather-topology
+ chmod +x $(DESTDIR)$(bindir)/hwloc-gather-topology
+
+ SUBDIRS = gather
diff --git a/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild b/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild
index 33efee375346..8d38ba7e1f71 100644
--- a/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild
+++ b/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild,v 1.2 2015/01/05 17:56:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild,v 1.3 2015/04/22 15:30:39 jsbronder Exp $
EAPI=5
@@ -69,4 +69,9 @@ src_configure() {
src_install() {
autotools-utils_src_install
+
+ # Fixed by upstream, but it seems overkill to require an autoregen for what
+ # is just a sed fix.
+ # https://github.com/open-mpi/hwloc/commit/6d42748f8604f3c1d0ca6cf122e8776b3c153ac4?diff=unified
+ sed -i 's|bindir/lstopo/|bindir/|' "${ED}"/usr/bin/hwloc-gather-topology || die
}
diff --git a/sys-apps/hwloc/hwloc-1.10.1.ebuild b/sys-apps/hwloc/hwloc-1.10.1.ebuild
index 8dc305283925..c27b854ca0c3 100644
--- a/sys-apps/hwloc/hwloc-1.10.1.ebuild
+++ b/sys-apps/hwloc/hwloc-1.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.10.1.ebuild,v 1.1 2015/02/20 15:26:40 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.10.1.ebuild,v 1.2 2015/04/22 15:30:39 jsbronder Exp $
EAPI=5
@@ -37,7 +37,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README VERSION )
-PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.1-gl.patch"
+ "${FILESDIR}/hwloc-gather-topology-fix-lstopo-path-after-install.patch"
+)
AUTOTOOLS_AUTORECONF=1
src_prepare() {