summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-15 03:49:39 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-15 03:49:39 +0000
commit83b53ac60aa8e1c9131f4c802cb8c4cabbb930ed (patch)
tree8b192bac92447c02939f58ce68ade79eaa02e2e8 /sys-apps
parentFix conf.d/local -> local.d transition for bug #363637. (diff)
downloadgentoo-2-83b53ac60aa8e1c9131f4c802cb8c4cabbb930ed.tar.gz
gentoo-2-83b53ac60aa8e1c9131f4c802cb8c4cabbb930ed.tar.bz2
gentoo-2-83b53ac60aa8e1c9131f4c802cb8c4cabbb930ed.zip
Change via into openchrome (bug #363661).
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwsetup/ChangeLog10
-rw-r--r--sys-apps/hwsetup/files/1.2-7-openchrome.patch11
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2-r2.ebuild62
3 files changed, 81 insertions, 2 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index 40c92af8d82c..59088a7dd685 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwsetup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.61 2009/10/04 15:18:13 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.62 2011/04/15 03:49:39 jer Exp $
+
+*hwsetup-1.2-r2 (15 Apr 2011)
+
+ 15 Apr 2011; Jeroen Roovers <jer@gentoo.org> +hwsetup-1.2-r2.ebuild,
+ +files/1.2-7-openchrome.patch:
+ Change via into openchrome (bug #363661).
04 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> hwsetup-1.2.ebuild:
Replace filtering of -Wl,--as-needed with function from flag-o-matic
diff --git a/sys-apps/hwsetup/files/1.2-7-openchrome.patch b/sys-apps/hwsetup/files/1.2-7-openchrome.patch
new file mode 100644
index 000000000000..641c3447aa49
--- /dev/null
+++ b/sys-apps/hwsetup/files/1.2-7-openchrome.patch
@@ -0,0 +1,11 @@
+--- a/hwsetup-1.2/hwsetup.c
++++ b/hwsetup-1.2/hwsetup.c
+@@ -456,7 +456,7 @@
+ else if(strcasestr(xi.xdesc,"Newport")) strcpy(xi.xmodule,"newport");
+ else if(strcasestr(xi.xdesc,"Siliconmotion")||strcasestr(xi.xdesc,"Silicon Motion")) strcpy(xi.xmodule,"siliconmotion");
+ else if(strcasestr(xi.xdesc,"Chips")) strcpy(xi.xmodule,"chips");
+- else if(strcasestr(xi.xdesc,"VIA ")) strcpy(xi.xmodule,"via");
++ else if(strcasestr(xi.xdesc,"VIA ")) strcpy(xi.xmodule,"openchrome");
+ }
+ else strcpy(xi.xmodule,xvesa4);
+ }
diff --git a/sys-apps/hwsetup/hwsetup-1.2-r2.ebuild b/sys-apps/hwsetup/hwsetup-1.2-r2.ebuild
new file mode 100644
index 000000000000..1c09f88dff2b
--- /dev/null
+++ b/sys-apps/hwsetup/hwsetup-1.2-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r2.ebuild,v 1.1 2011/04/15 03:49:39 jer Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_PV=${PV}-7
+DESCRIPTION="Hardware setup program from Knoppix - used only on LiveCD"
+HOMEPAGE="http://www.knopper.net/"
+SRC_URI="http://debian-knoppix.alioth.debian.org/sources/${PN}_${MY_PV}.tar.gz"
+#http://developer.linuxtag.net/knoppix/sources/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 -mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="zlib"
+
+COMMON_DEPEND="zlib? ( sys-libs/zlib )
+ sys-apps/pciutils"
+DEPEND="${COMMON_DEPEND}
+ sys-libs/libkudzu"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/hwdata-gentoo"
+
+pkg_setup() {
+ ewarn "This package is designed for use on the LiveCD only and will do "
+ ewarn "unspeakably horrible and unexpected things on a normal system."
+ ewarn "YOU HAVE BEEN WARNED!!!"
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch \
+ "${FILESDIR}"/${MY_PV}-dyn_blacklist.patch \
+ "${FILESDIR}"/${PV}-3-fastprobe.patch \
+ "${FILESDIR}"/${MY_PV}-gentoo.patch \
+ "${FILESDIR}"/${PV}-strip.patch \
+ "${FILESDIR}"/${MY_PV}-openchrome.patch
+}
+
+src_compile() {
+ if use zlib ; then
+ sed -i \
+ -e '/^LIBS=/s,-lpci,-lz -lpci,g' \
+ Makefile
+ elif built_with_use --missing false sys-apps/pciutils zlib ; then
+ die "You need to build with USE=zlib to match sys-apps/pcituils"
+ fi
+ emake LDFLAGS="${LDFLAGS}" OPT="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR="${D}" PREFIX=/usr MANDIR=/usr/share/man || die "Install failed"
+ keepdir /etc/sysconfig
+}
+
+pkg_postinst() {
+ ewarn "This package is intended for usage on the Gentoo release media. If"
+ ewarn "you are not building a CD, remove this package. It will not work"
+ ewarn "properly on a running system, as Gentoo does not use any of the"
+ ewarn "Knoppix-style detection except for CD builds."
+}