summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-03-28 01:24:32 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-03-28 01:24:32 +0000
commitabd371ae32d30cb699d35afa28332a771f8fa13e (patch)
tree30d52e15fdd65ae84b7945529c674fbe54a5121a /sys-apps
parentStable on x86 (diff)
downloadgentoo-2-abd371ae32d30cb699d35afa28332a771f8fa13e.tar.gz
gentoo-2-abd371ae32d30cb699d35afa28332a771f8fa13e.tar.bz2
gentoo-2-abd371ae32d30cb699d35afa28332a771f8fa13e.zip
fix install location of python site packages.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/policycoreutils/ChangeLog8
-rw-r--r--sys-apps/policycoreutils/files/digest-policycoreutils-1.30-r1 (renamed from sys-apps/policycoreutils/files/digest-policycoreutils-1.30)0
-rw-r--r--sys-apps/policycoreutils/policycoreutils-1.30-r1.ebuild (renamed from sys-apps/policycoreutils/policycoreutils-1.30.ebuild)19
3 files changed, 22 insertions, 5 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index 21f0f8883fbb..a4ec312f991f 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.56 2006/03/18 15:01:24 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.57 2006/03/28 01:24:32 pebenito Exp $
+
+*policycoreutils-1.30-r1 (28 Mar 2006)
+
+ 28 Mar 2006; Chris PeBenito <pebenito@gentoo.org>
+ -policycoreutils-1.30.ebuild, +policycoreutils-1.30-r1.ebuild:
+ Fix install location of python site packages.
22 Feb 2006; Stephen Bennett <spb@gentoo.org> policycoreutils-1.28.ebuild:
Alpha stable
diff --git a/sys-apps/policycoreutils/files/digest-policycoreutils-1.30 b/sys-apps/policycoreutils/files/digest-policycoreutils-1.30-r1
index 2081dac9d715..2081dac9d715 100644
--- a/sys-apps/policycoreutils/files/digest-policycoreutils-1.30
+++ b/sys-apps/policycoreutils/files/digest-policycoreutils-1.30-r1
diff --git a/sys-apps/policycoreutils/policycoreutils-1.30.ebuild b/sys-apps/policycoreutils/policycoreutils-1.30-r1.ebuild
index 04caf9b6435f..4bb82fc4a7a0 100644
--- a/sys-apps/policycoreutils/policycoreutils-1.30.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-1.30-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.30.ebuild,v 1.1 2006/03/18 15:01:24 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.30-r1.ebuild,v 1.1 2006/03/28 01:24:32 pebenito Exp $
IUSE="build nls pam"
-inherit eutils
+inherit eutils python
EXTRAS_VER="1.15"
SEMNG_VER="1.6"
@@ -91,23 +91,25 @@ src_unpack() {
}
src_compile() {
+ python_version
if useq build; then
einfo "Compiling setfiles"
emake -C ${S}/setfiles || die
else
einfo "Compiling policycoreutils"
- emake -C ${S} || die
+ emake -C ${S} PYLIBVER="python${PYVER}" || die
einfo "Compiling policycoreutils-extra"
emake -C ${S2} || die
fi
}
src_install() {
+ python_version
if useq build; then
dosbin ${S}/setfiles/setfiles
else
einfo "Installing policycoreutils"
- make DESTDIR="${D}" -C ${S} install || die
+ make DESTDIR="${D}" -C ${S} PYLIBVER="python${PYVER}" install || die
einfo "Installing policycoreutils-extra"
make DESTDIR="${D}" -C ${S2} install || die
fi
@@ -116,6 +118,8 @@ src_install() {
}
pkg_postinst() {
+ python_version
+
if useq build; then
# need to ensure these
mkdir -p ${ROOT}/selinux
@@ -127,5 +131,12 @@ pkg_postinst() {
chmod 0666 ${ROOT}/dev/{ptmx,tty}
fi
+ python_mod_optimize ${ROOT}usr/lib/python${PYVER}/site-packages
+
throw_pam_warning
}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup ${ROOT}usr/lib/python${PYVER}/site-packages
+}