summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-14 21:15:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-14 21:15:17 +0000
commitbd238359cc4c6abec5103183e9c672976cc694ed (patch)
tree49cff15f3057f10feb28955732fd2d1889c4a55e /sys-apps
parentVersion bump. Lots of bugfixes. (diff)
downloadgentoo-2-bd238359cc4c6abec5103183e9c672976cc694ed.tar.gz
gentoo-2-bd238359cc4c6abec5103183e9c672976cc694ed.tar.bz2
gentoo-2-bd238359cc4c6abec5103183e9c672976cc694ed.zip
Version bump wrt #319771 without HAL support wrt #313389.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pmount/ChangeLog7
-rw-r--r--sys-apps/pmount/pmount-0.9.22.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index 633b3b44efd8..659bae2f8d7d 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.79 2010/01/30 18:15:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.80 2010/05/14 21:15:17 ssuominen Exp $
+
+*pmount-0.9.22 (14 May 2010)
+
+ 14 May 2010; Samuli Suominen <ssuominen@gentoo.org> +pmount-0.9.22.ebuild:
+ Version bump wrt #319771 without HAL support wrt #313389.
30 Jan 2010; Jeroen Roovers <jer@gentoo.org> pmount-0.9.20.ebuild:
Stable for HPPA (bug #299381).
diff --git a/sys-apps/pmount/pmount-0.9.22.ebuild b/sys-apps/pmount/pmount-0.9.22.ebuild
new file mode 100644
index 000000000000..d0f73e504983
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.22.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.22.ebuild,v 1.1 2010/05/14 21:15:17 ssuominen Exp $
+
+EAPI=2
+inherit base eutils
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/3293/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt"
+
+RDEPEND=">=sys-apps/util-linux-2.16
+ crypt? ( >=sys-fs/cryptsetup-1.0.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.19-testsuite-missing-dir.patch" )
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-hal
+}
+
+src_test() {
+ local testdir=${S}/tests/check_fstab
+
+ ln -s $testdir/a $testdir/b && ln -s $testdir/d $testdir/c && \
+ ln -s $testdir/c $testdir/e \
+ || die "Unable to create fake symlinks required for testsuite"
+ emake check || die
+}
+
+src_install () {
+ # Must be run SETUID+SETGID, bug #250106
+ exeinto /usr/bin
+ exeopts -m 6710 -g plugdev
+ doexe src/pmount src/pumount || die
+
+ dodoc AUTHORS ChangeLog TODO || die
+ doman man/pmount.1 man/pumount.1 || die
+
+ insinto /etc
+ doins etc/pmount.allow || die
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid and setgid."
+
+ elog "The permissions are as such that only users that belong to the plugdev"
+ elog "group are allowed to run this. But if a script run by root mounts a"
+ elog "device, members of the plugdev group will have access to it."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}