summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-08 13:12:32 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-06-08 13:12:32 +0000
commitca469b7686240b71966f0473071d05b29818e4b9 (patch)
tree1ffe1fcef420043c1a3a367ec5fbf7e7ba519d4c /sys-apps
parentUpdate jakarta-jstl dependency. Remove old. Fix bug 551032. (diff)
downloadgentoo-2-ca469b7686240b71966f0473071d05b29818e4b9.tar.gz
gentoo-2-ca469b7686240b71966f0473071d05b29818e4b9.tar.bz2
gentoo-2-ca469b7686240b71966f0473071d05b29818e4b9.zip
Fix bug #550654.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/install-xattr/ChangeLog8
-rw-r--r--sys-apps/install-xattr/install-xattr-0.5.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/install-xattr/ChangeLog b/sys-apps/install-xattr/ChangeLog
index 47ddc3c3d908..56d271878b53 100644
--- a/sys-apps/install-xattr/ChangeLog
+++ b/sys-apps/install-xattr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/install-xattr
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/ChangeLog,v 1.35 2015/04/25 16:36:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/ChangeLog,v 1.36 2015/06/08 13:12:32 blueness Exp $
+
+*install-xattr-0.5 (08 Jun 2015)
+
+ 08 Jun 2015; Anthony G. Basile <blueness@gentoo.org>
+ +install-xattr-0.5.ebuild:
+ Fix bug #550654.
25 Apr 2015; Mike Gilbert <floppym@gentoo.org> install-xattr-0.3.ebuild,
install-xattr-0.4.ebuild, install-xattr-9999.ebuild:
diff --git a/sys-apps/install-xattr/install-xattr-0.5.ebuild b/sys-apps/install-xattr/install-xattr-0.5.ebuild
new file mode 100644
index 000000000000..e1a3e642eead
--- /dev/null
+++ b/sys-apps/install-xattr/install-xattr-0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-0.5.ebuild,v 1.1 2015/06/08 13:12:32 blueness Exp $
+
+EAPI=5
+DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
+HOMEPAGE="http://dev.gentoo.org/~blueness/install-xattr/"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
+ KEYWORDS=""
+ inherit git-2
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S=${WORKDIR}/${PN}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+src_install() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+# We need to fix how tests are done
+src_test() {
+ true
+}