summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-06-28 12:02:46 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-06-28 12:02:46 +0000
commitddef1c8a938a139d0fe25fb318e53fddfd8f0928 (patch)
tree207d7f4a137cdecb9508b2f33ffdda57eaf2f2c5 /sys-apps
parentPackage now installs man page properly. (diff)
downloadgentoo-2-ddef1c8a938a139d0fe25fb318e53fddfd8f0928.tar.gz
gentoo-2-ddef1c8a938a139d0fe25fb318e53fddfd8f0928.tar.bz2
gentoo-2-ddef1c8a938a139d0fe25fb318e53fddfd8f0928.zip
Package now installs man page properly.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/thinkpad/ChangeLog7
-rw-r--r--sys-apps/thinkpad/Manifest6
-rw-r--r--sys-apps/thinkpad/files/digest-thinkpad-4.3-r11
-rw-r--r--sys-apps/thinkpad/thinkpad-4.3-r1.ebuild68
-rw-r--r--sys-apps/thinkpad/thinkpad-4.3.ebuild3
5 files changed, 80 insertions, 5 deletions
diff --git a/sys-apps/thinkpad/ChangeLog b/sys-apps/thinkpad/ChangeLog
index 848ea0693461..d6c07104fb6b 100644
--- a/sys-apps/thinkpad/ChangeLog
+++ b/sys-apps/thinkpad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/thinkpad
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.7 2003/05/04 13:19:50 wmertens Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.8 2003/06/28 12:02:37 karltk Exp $
+
+*thinkpad-4.3-r1 (27 Jun 2003)
+
+ 27 Jun 2003; Karl Trygve Kalleberg <karltk@gentoo.org> thinkpad-4.3-r1.ebuild :
+ version bump, installs man page now.
*thinkpad-4.3 (04 May 2003)
diff --git a/sys-apps/thinkpad/Manifest b/sys-apps/thinkpad/Manifest
index 0d81134acb02..66a4885db30c 100644
--- a/sys-apps/thinkpad/Manifest
+++ b/sys-apps/thinkpad/Manifest
@@ -1,8 +1,8 @@
-MD5 3f384115ce2424e9578131218d0eb7c1 ChangeLog 1579
+MD5 ffcd0f9cadf445e3d62a15ccbb552979 ChangeLog 1576
MD5 572a06d9b04d1d73d90935c504ae02aa thinkpad-3.2.ebuild 1490
MD5 e1e0c6c14e5f2cc194ae5b17b1754c33 thinkpad-4.1.ebuild 1524
-MD5 6c4e34a839807bb793d84c5a33be2c8e thinkpad-4.3.ebuild 2063
-MD5 91910f11f8902cf8b4bd49afc2d4a4b0 thinkpad-4.3-r1.ebuild 2063
+MD5 785b2dae70a5c8bfed5f439b6e6cd7af thinkpad-4.3.ebuild 2060
+MD5 17f1394169c2235e87af080f488a7955 thinkpad-4.3-r1.ebuild 2063
MD5 67a420196c59076408625a82b1b0f3eb files/digest-thinkpad-3.2 63
MD5 f6711c6d29ed136c770235acf6bebf4a files/digest-thinkpad-4.1 63
MD5 c4bd4b11c836429cb452ababe9575efd files/digest-thinkpad-4.3 63
diff --git a/sys-apps/thinkpad/files/digest-thinkpad-4.3-r1 b/sys-apps/thinkpad/files/digest-thinkpad-4.3-r1
new file mode 100644
index 000000000000..53dacb1f3fe8
--- /dev/null
+++ b/sys-apps/thinkpad/files/digest-thinkpad-4.3-r1
@@ -0,0 +1 @@
+MD5 af8dfd6e1529ee07620c2e4f11f05702 thinkpad_4.3.tar.gz 84492
diff --git a/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild b/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild
new file mode 100644
index 000000000000..ac35ff88adf4
--- /dev/null
+++ b/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild,v 1.1 2003/06/28 12:02:37 karltk Exp $
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+DESCRIPTION="Thinkpad system control kernel modules"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="x86 amd64 -ppc -mips -sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ check_KV
+ unpack ${A} || die
+ cd ${S}
+
+ # Use the correct drivers for your kernel. The standard distro comes
+ # with 2.5.
+ mkdir 2.5
+ mv drivers include 2.5
+ # Use your kernel version to build.
+ local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :)
+ ln -s $ver/drivers drivers
+ ln -s $ver/include include
+}
+
+src_compile() {
+ check_KV
+ emake DIR_MOD_VER=/lib/modules/${KV} || die "Make failed"
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
+ ${D}/lib/modules/${KV}/thinkpad
+ dodir /etc/modules.d
+ sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
+ dodir /etc/devfs.d
+ echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \
+ > ${D}/etc/devfs.d/thinkpad
+ doman man/*.4
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules || return 0
+ if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then
+ ewarn 'Your /etc/devfsd.conf is missing the include for'
+ ewarn '/etc/devfs.d/! Please fix this by adding'
+ ewarn 'INCLUDE /etc/devfs.d'
+ ewarn 'to your /etc/devfs.conf'
+ fi
+ if grep -q thinkpad /etc/devfsd.conf; then
+ ewarn 'The thinkpad devfsd entry has moved to'
+ ewarn '/etc/devfs.d/thinkpad, so you can remove it from'
+ ewarn '/etc/devfsd.conf if you like.'
+ fi
+}
+
+pkg_prerm() {
+ /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+}
diff --git a/sys-apps/thinkpad/thinkpad-4.3.ebuild b/sys-apps/thinkpad/thinkpad-4.3.ebuild
index 0203f7818641..decb8de735e5 100644
--- a/sys-apps/thinkpad/thinkpad-4.3.ebuild
+++ b/sys-apps/thinkpad/thinkpad-4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.3.ebuild,v 1.2 2003/06/21 21:19:41 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.3.ebuild,v 1.3 2003/06/28 12:02:37 karltk Exp $
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
@@ -45,6 +45,7 @@ src_install() {
dodir /etc/devfs.d
echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \
> ${D}/etc/devfs.d/thinkpad
+ doman man/*.1
}
pkg_postinst() {