summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-12-29 04:48:23 +0000
committerMatt Turner <mattst88@gentoo.org>2012-12-29 04:48:23 +0000
commit357ef10c400ee630c0a55752ab6e3c2de8b6d789 (patch)
tree90f1a5566108155a17b745c3754d1724e6b51899 /sys-auth/pam_mount
parentVersion bump. (diff)
downloadgentoo-2-357ef10c400ee630c0a55752ab6e3c2de8b6d789.tar.gz
gentoo-2-357ef10c400ee630c0a55752ab6e3c2de8b6d789.tar.bz2
gentoo-2-357ef10c400ee630c0a55752ab6e3c2de8b6d789.zip
Fix bugs #379267 and #395147.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog9
-rw-r--r--sys-auth/pam_mount/files/pam_mount-2.13-fix-build-without-cryptsetup.patch22
-rw-r--r--sys-auth/pam_mount/files/pam_mount-2.13-remove-useless-log-message.patch14
-rw-r--r--sys-auth/pam_mount/pam_mount-2.13-r1.ebuild49
4 files changed, 93 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 6f0c74fcdd8c..11096932f3fd 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.67 2012/05/28 00:17:34 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.68 2012/12/29 04:48:23 mattst88 Exp $
+
+*pam_mount-2.13-r1 (29 Dec 2012)
+
+ 29 Dec 2012; Matt Turner <mattst88@gentoo.org> +pam_mount-2.13-r1.ebuild,
+ +files/pam_mount-2.13-fix-build-without-cryptsetup.patch,
+ +files/pam_mount-2.13-remove-useless-log-message.patch:
+ Fix bugs #379267 and #395147.
28 May 2012; Matt Turner <mattst88@gentoo.org> -pam_mount-2.1.ebuild,
-pam_mount-2.5.ebuild, -pam_mount-2.6.ebuild,
diff --git a/sys-auth/pam_mount/files/pam_mount-2.13-fix-build-without-cryptsetup.patch b/sys-auth/pam_mount/files/pam_mount-2.13-fix-build-without-cryptsetup.patch
new file mode 100644
index 000000000000..4733c6b62dd7
--- /dev/null
+++ b/sys-auth/pam_mount/files/pam_mount-2.13-fix-build-without-cryptsetup.patch
@@ -0,0 +1,22 @@
+diff -ruN pam_mount-2.13.orig/src/Makefile.am pam_mount-2.13/src/Makefile.am
+--- pam_mount-2.13.orig/src/Makefile.am 2011-12-15 04:12:10.000000000 -0800
++++ pam_mount-2.13/src/Makefile.am 2012-12-28 20:41:44.878975018 -0800
+@@ -8,7 +8,9 @@
+ moduledir = @PAM_MODDIR@
+ module_LTLIBRARIES = pam_mount.la
+ sbin_PROGRAMS = pmvarrun
++if HAVE_LIBCRYPTSETUP
+ sbin_PROGRAMS += pmt-ehd
++endif
+ ssbin_PROGRAMS = mount.crypt
+ noinst_PROGRAMS = autoloop ismnt
+ noinst_SCRIPTS = umount.crypt
+@@ -75,7 +77,7 @@
+ mount_crypt_LDADD = libcryptmount.la libpmt_mtab.la ${libHX_LIBS}
+
+ pmt_ehd_SOURCES = ehd.c bdev.c misc.c spawn.c
+-pmt_ehd_LDADD = libcryptmount.la ${libHX_LIBS}
++pmt_ehd_LDADD = libcryptmount.la ${libHX_LIBS} ${libcryptsetup_LIBS}
+
+ #
+ # runtime helpers
diff --git a/sys-auth/pam_mount/files/pam_mount-2.13-remove-useless-log-message.patch b/sys-auth/pam_mount/files/pam_mount-2.13-remove-useless-log-message.patch
new file mode 100644
index 000000000000..8f5e58dc6bd3
--- /dev/null
+++ b/sys-auth/pam_mount/files/pam_mount-2.13-remove-useless-log-message.patch
@@ -0,0 +1,14 @@
+X-Git-Url: http://pam-mount.git.sourceforge.net/git/gitweb.cgi?p=pam-mount%2Fpam-mount;a=blobdiff_plain;f=src%2Frdconf1.c;h=827d36ad2a8873f9342c9fd94fae506dabf5f4af;hp=e8ccd2d4fc96811986a1bd9e57bc8803d93576aa;hb=38a15cc36c7fe6714dd3010fde6ad808b3792ac0;hpb=8bbab5ce3520d361398bdcd65290af8f9cd8ea64
+
+diff --git a/src/rdconf1.c b/src/rdconf1.c
+index e8ccd2d..827d36a 100644
+--- a/src/rdconf1.c
++++ b/src/rdconf1.c
+@@ -340,6 +340,7 @@ void initconfig(struct config *config)
+ char options_require[] = "nosuid,nodev";
+
+ memset(config, 0, sizeof(*config));
++ ehd_logctl(EHD_LOGFT_DEBUG, EHD_LOG_SET);
+ config->debug = true;
+ config->mkmntpoint = true;
+
diff --git a/sys-auth/pam_mount/pam_mount-2.13-r1.ebuild b/sys-auth/pam_mount/pam_mount-2.13-r1.ebuild
new file mode 100644
index 000000000000..d4b41476bab2
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.13-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.13-r1.ebuild,v 1.1 2012/12/29 04:48:23 mattst88 Exp $
+
+EAPI=4
+
+inherit eutils multilib autotools
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-arch/xz-utils"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-build-without-cryptsetup.patch
+ epatch "${FILESDIR}"/${P}-remove-useless-log-message.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}