summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-31 02:24:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-31 02:24:10 +0000
commitdadd9c6ef241b9249868125f46b43619f4e2242c (patch)
tree006011c672c03dffead32d221382f42a1fd87cba /sys-auth/ykclient
parentVersion bump; add support for consolekit/udev. (diff)
downloadgentoo-2-dadd9c6ef241b9249868125f46b43619f4e2242c.tar.gz
gentoo-2-dadd9c6ef241b9249868125f46b43619f4e2242c.tar.bz2
gentoo-2-dadd9c6ef241b9249868125f46b43619f4e2242c.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-auth/ykclient')
-rw-r--r--sys-auth/ykclient/ChangeLog7
-rw-r--r--sys-auth/ykclient/ykclient-2.9.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-auth/ykclient/ChangeLog b/sys-auth/ykclient/ChangeLog
index faf67c52a851..a407cf7f71d1 100644
--- a/sys-auth/ykclient/ChangeLog
+++ b/sys-auth/ykclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykclient
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.3 2012/06/24 10:33:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.4 2012/12/31 02:24:10 flameeyes Exp $
+
+*ykclient-2.9 (31 Dec 2012)
+
+ 31 Dec 2012; Diego E. Pettenò <flameeyes@gentoo.org> +ykclient-2.9.ebuild:
+ Version bump.
24 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> -ykclient-2.3.ebuild:
Remove ebuild as well.
diff --git a/sys-auth/ykclient/ykclient-2.9.ebuild b/sys-auth/ykclient/ykclient-2.9.ebuild
new file mode 100644
index 000000000000..10bc9fe412c6
--- /dev/null
+++ b/sys-auth/ykclient/ykclient-2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ykclient-2.9.ebuild,v 1.1 2012/12/31 02:24:10 flameeyes Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Yubico C client library"
+SRC_URI="http://yubico-c-client.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubico-c-client"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs"
+
+RDEPEND=">=net-misc/curl-7.21.1"
+DEPEND="${RDEPEND}"
+
+# Tests require an active network connection, we don't want to run them
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ prune_libtool_files
+}