summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-04-22 13:23:20 +0000
committerRick Farina <zerochaos@gentoo.org>2013-04-22 13:23:20 +0000
commit2d1e6533b2272785d6ad87af18bfed44ead1719e (patch)
tree4c519ee1bb0ca87b0808e6f4c4fd790785f118a5 /sys-auth/ykpers
parenttested on ~x86 (diff)
downloadgentoo-2-2d1e6533b2272785d6ad87af18bfed44ead1719e.tar.gz
gentoo-2-2d1e6533b2272785d6ad87af18bfed44ead1719e.tar.bz2
gentoo-2-2d1e6533b2272785d6ad87af18bfed44ead1719e.zip
version bump, quick tests show it works
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth/ykpers')
-rw-r--r--sys-auth/ykpers/ChangeLog7
-rw-r--r--sys-auth/ykpers/ykpers-1.13.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
index d24c3b0c7eee..df7fe8c0f98c 100644
--- a/sys-auth/ykpers/ChangeLog
+++ b/sys-auth/ykpers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykpers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.8 2013/03/17 17:37:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.9 2013/04/22 13:23:20 zerochaos Exp $
+
+*ykpers-1.13.0 (22 Apr 2013)
+
+ 22 Apr 2013; Rick Farina <zerochaos@gentoo.org> +ykpers-1.13.0.ebuild:
+ version bump, quick tests show it works
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/sys-auth/ykpers/ykpers-1.13.0.ebuild b/sys-auth/ykpers/ykpers-1.13.0.ebuild
new file mode 100644
index 000000000000..cb1671b3e310
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.13.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.13.0.ebuild,v 1.1 2013/04/22 13:23:20 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND=">=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ dodoc doc/*
+ prune_libtool_files
+
+ use consolekit && \
+ udev_dorules 70-yubikey.rules
+}