summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-07-22 22:27:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-07-22 22:27:37 +0000
commit11b69939343e78e8e24f94fc198116bc5572c57d (patch)
tree92ff94168bdaaed9a9608db60a8943f1dc21d8b3 /sys-auth
parentAdd ssh USE flag for pambase. (diff)
downloadgentoo-2-11b69939343e78e8e24f94fc198116bc5572c57d.tar.gz
gentoo-2-11b69939343e78e8e24f94fc198116bc5572c57d.tar.bz2
gentoo-2-11b69939343e78e8e24f94fc198116bc5572c57d.zip
Add new pambase version, with added support for sys-auth/pam_ssh. Also contains fixes for bug #232669 for Gentoo/FreeBSD 7 systems. See bug #232691 for keywording request.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pambase/ChangeLog10
-rw-r--r--sys-auth/pambase/metadata.xml7
-rw-r--r--sys-auth/pambase/pambase-20080723.ebuild85
3 files changed, 101 insertions, 1 deletions
diff --git a/sys-auth/pambase/ChangeLog b/sys-auth/pambase/ChangeLog
index a5adbbb9a641..bd8d735a2ecc 100644
--- a/sys-auth/pambase/ChangeLog
+++ b/sys-auth/pambase/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-auth/pambase
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.40 2008/07/04 19:43:58 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.41 2008/07/22 22:27:37 flameeyes Exp $
+
+*pambase-20080723 (22 Jul 2008)
+
+ 22 Jul 2008; Diego Pettenò <flameeyes@gentoo.org> metadata.xml,
+ +pambase-20080723.ebuild:
+ Add new pambase version, with added support for sys-auth/pam_ssh. Also
+ contains fixes for bug #232669 for Gentoo/FreeBSD 7 systems. See bug
+ #232691 for keywording request.
04 Jul 2008; <ricmm@gentoo.org> pambase-20080318.ebuild:
Add ~mips, bug #230743
diff --git a/sys-auth/pambase/metadata.xml b/sys-auth/pambase/metadata.xml
index d0622efecd0f..ace595126384 100644
--- a/sys-auth/pambase/metadata.xml
+++ b/sys-auth/pambase/metadata.xml
@@ -40,5 +40,12 @@
handling. This module creates a private temporary directory for
the user, and sets TMP and TMPDIR accordingly.
</flag>
+ <flag name="ssh">
+ Enable pam_ssh module on system auth stack for authentication
+ and session handling. This module will accept as password the
+ passphrase of a private SSH key (one of ~/.ssh/id_rsa,
+ ~/.ssh/id_dsa or ~/.ssh/identity), and will spawn an ssh-agent
+ instance to cache the open key.
+ </flag>
</use>
</pkgmetadata>
diff --git a/sys-auth/pambase/pambase-20080723.ebuild b/sys-auth/pambase/pambase-20080723.ebuild
new file mode 100644
index 000000000000..97a01aa6fb31
--- /dev/null
+++ b/sys-auth/pambase/pambase-20080723.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20080723.ebuild,v 1.1 2008/07/22 22:27:37 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM base configuration files"
+HOMEPAGE="http://www.gentoo.org/proj/en/base/pam/"
+SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug cracklib passwdqc consolekit gnome-keyring selinux mktemp ssh"
+RESTRICT="binchecks"
+
+RDEPEND="
+ || (
+ >=sys-libs/pam-0.99.9.0-r1
+ ( sys-auth/openpam
+ || ( sys-freebsd/freebsd-pam-modules sys-netbsd/netbsd-pam-modules )
+ )
+ )
+ cracklib? ( >=sys-libs/pam-0.99 )
+ consolekit? ( sys-auth/consolekit )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.20 )
+ selinux? ( >=sys-libs/pam-0.99 )
+ passwdqc? ( >=sys-auth/pam_passwdqc-1.0.4 )
+ mktemp? ( sys-auth/pam_mktemp )
+ ssh? ( sys-auth/pam_ssh )
+ !<sys-freebsd/freebsd-pam-modules-6.2-r1
+ !<sys-libs/pam-0.99.9.0-r1"
+DEPEND=""
+
+pkg_setup() {
+ if use cracklib && ! built_with_use sys-libs/pam cracklib; then
+ eerror "To enable cracklib support in the main PAM configuration"
+ eerror "you need to enable cracklib USE flag on sys-libs/pam"
+ eerror "first."
+ die "Missing pam_cracklib"
+ fi
+
+ if use selinux && ! built_with_use sys-libs/pam selinux; then
+ eerror "To enable selinux support in the main PAM configuration"
+ eerror "you need to enable selinux USE flag on sys-libs/pam"
+ eerror "first."
+ die "Missing pam_selinux"
+ fi
+
+ if use consolekit && ! built_with_use sys-auth/consolekit pam; then
+ eerror "To enable ConsoleKit support in the main PAM configuration"
+ eerror "you need to enable pam USE flag on sys-auth/consolekit"
+ eerror "first."
+ die "Missing pam_ck_connector"
+ fi
+
+ if use gnome-keyring && ! built_with_use gnome-base/gnome-keyring pam; then
+ eerror "To enable GNOME Keyring support in the main PAM configuration"
+ eerror "you need to enable pam USE flag on gnome-base/gnome-keyring"
+ eerror "first."
+ die "Missing pam_gnome_keyring"
+ fi
+}
+
+src_compile() {
+ has_version sys-libs/pam && implementation="linux-pam"
+ has_version sys-auth/openpam && implementation="openpam"
+
+ emake \
+ GIT=true \
+ DEBUG=$(use debug && echo yes || echo no) \
+ CRACKLIB=$(use cracklib && echo yes || echo no) \
+ PASSWDQC=$(use passwdqc && echo yes || echo no) \
+ CONSOLEKIT=$(use consolekit && echo yes || echo no) \
+ GNOME_KEYRING=$(use gnome-keyring && echo yes || echo no) \
+ SELINUX=$(use selinux && echo yes || echo no) \
+ MKTEMP=$(use mktemp && echo yes || echo no) \
+ PAM_SSH=$(use ssh && echo yes || echo no) \
+ IMPLEMENTATION=${implementation} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake GIT=true DESTDIR="${D}" install || die "emake install failed"
+}