summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-06 09:41:47 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-06 09:41:47 +0000
commit8ba6732e401ac5e061f80b323c7636a15abdcde6 (patch)
treebb67c4c4983e1ffb9caf51e3da77ceae41db7987 /sys-auth
parentAdd ~sparc, wrt bug #449220 (diff)
downloadgentoo-2-8ba6732e401ac5e061f80b323c7636a15abdcde6.tar.gz
gentoo-2-8ba6732e401ac5e061f80b323c7636a15abdcde6.tar.bz2
gentoo-2-8ba6732e401ac5e061f80b323c7636a15abdcde6.zip
Version bump (thanks Matthias Blümel, bug 450274), new drivers aes1660, aes2550, aes2660, vfs301. vcs-snapshot eclass.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libfprint/ChangeLog8
-rw-r--r--sys-auth/libfprint/libfprint-0.5.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-auth/libfprint/ChangeLog b/sys-auth/libfprint/ChangeLog
index 4b5da2d41cb4..3ede792985c6 100644
--- a/sys-auth/libfprint/ChangeLog
+++ b/sys-auth/libfprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/libfprint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.15 2013/01/01 14:53:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.16 2013/01/06 09:41:47 xmw Exp $
+
+*libfprint-0.5.0 (06 Jan 2013)
+
+ 06 Jan 2013; Michael Weber <xmw@gentoo.org> +libfprint-0.5.0.ebuild:
+ Version bump (thanks Matthias Blümel, bug 450274), new drivers aes1660,
+ aes2550, aes2660, vfs301. vcs-snapshot eclass.
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> libfprint-0.4.0.ebuild:
Add ~alpha, wrt bug #449220
diff --git a/sys-auth/libfprint/libfprint-0.5.0.ebuild b/sys-auth/libfprint/libfprint-0.5.0.ebuild
new file mode 100644
index 000000000000..edeb9c8808d4
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.5.0.ebuild,v 1.1 2013/01/06 09:41:47 xmw Exp $
+
+EAPI=4
+
+inherit autotools udev vcs-snapshot
+
+MY_PV="v_${PV//./_}"
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/libusb:1
+ dev-libs/nss
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] x11-libs/gdk-pixbuf )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-drivers=all \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) \
+ --with-udev-rules \
+ --with-udev-rules-dir=$(udev_get_udevdir)/rules.d
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ prune_libtool_files
+
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
+}