summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-08-24 05:50:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-08-24 05:50:17 +0000
commit24f53cb87d6c0f92ebbb9bd8de7ad79274c6f9fd (patch)
treeecfc47797f979dc42b6248f8f507684f4c91d07d /sys-block/smp_utils/smp_utils-0.91.ebuild
parentstable on ppc (Bug #144925) (diff)
downloadgentoo-2-24f53cb87d6c0f92ebbb9bd8de7ad79274c6f9fd.tar.gz
gentoo-2-24f53cb87d6c0f92ebbb9bd8de7ad79274c6f9fd.tar.bz2
gentoo-2-24f53cb87d6c0f92ebbb9bd8de7ad79274c6f9fd.zip
Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sys-block/smp_utils/smp_utils-0.91.ebuild')
-rw-r--r--sys-block/smp_utils/smp_utils-0.91.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-block/smp_utils/smp_utils-0.91.ebuild b/sys-block/smp_utils/smp_utils-0.91.ebuild
new file mode 100644
index 000000000000..586700809765
--- /dev/null
+++ b/sys-block/smp_utils/smp_utils-0.91.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/smp_utils/smp_utils-0.91.ebuild,v 1.1 2006/08/24 05:50:17 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Utilities for SAS management protocol (SMP)"
+HOMEPAGE="http://www.torque.net/sg/smp_utils.html"
+SRC_URI="http://www.torque.net/sg/p/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd "${S}"
+ for i in Makefile mpt/Makefile sas_tpl/Makefile ; do
+ sed -i \
+ -e "/^CFLAGS/s:-g -O2:${CFLAGS}:g" \
+ -e '/^PREFIX=/s:/local::' \
+ -e '/^INSTDIR=/s:/bin:/sbin:' \
+ -e 's:$(DESTDIR)/:$(DESTDIR):' \
+ -e "/^LIBDIR=/s:/lib$:/$(get_libdir):" \
+ -e '/^MANDIR=/s:)/man:)/share/man:' \
+ -e 's:install -s :install :' \
+ $i || die "sed of $i failed"
+ done
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc AUTHORS CHANGELOG COVERAGE CREDITS README* TODO
+ dohtml doc/*html
+ make install DESTDIR="${D}" || die "make install failed"
+}