summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-11-15 22:02:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-11-15 22:02:51 +0000
commit2944d7ec240ab55a64b049d9d272a44e14a42fbd (patch)
treefd41c9c103e568c5c7cedb12549393150d2ac706 /sys-block
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2944d7ec240ab55a64b049d9d272a44e14a42fbd.tar.gz
gentoo-2-2944d7ec240ab55a64b049d9d272a44e14a42fbd.tar.bz2
gentoo-2-2944d7ec240ab55a64b049d9d272a44e14a42fbd.zip
Version bump. Change the RESTRICT=fetch to primaryuri, and let upstream count the downloads that way. Also update my test list as some of that hardware is long gone.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/tw_cli/ChangeLog9
-rw-r--r--sys-block/tw_cli/tw_cli-10.2.ebuild107
2 files changed, 115 insertions, 1 deletions
diff --git a/sys-block/tw_cli/ChangeLog b/sys-block/tw_cli/ChangeLog
index 30a2d9e3921b..b4ef92bec1bd 100644
--- a/sys-block/tw_cli/ChangeLog
+++ b/sys-block/tw_cli/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/tw_cli
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/ChangeLog,v 1.32 2010/06/18 06:47:16 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/ChangeLog,v 1.33 2010/11/15 22:02:51 robbat2 Exp $
+
+*tw_cli-10.2 (15 Nov 2010)
+
+ 15 Nov 2010; Robin H. Johnson <robbat2@gentoo.org> +tw_cli-10.2.ebuild:
+ Version bump. Change the RESTRICT=fetch to primaryuri, and let upstream
+ count the downloads that way. Also update my test list as some of that
+ hardware is long gone.
*tw_cli-10.1 (18 Jun 2010)
diff --git a/sys-block/tw_cli/tw_cli-10.2.ebuild b/sys-block/tw_cli/tw_cli-10.2.ebuild
new file mode 100644
index 000000000000..da96ec2cbaf8
--- /dev/null
+++ b/sys-block/tw_cli/tw_cli-10.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/tw_cli/tw_cli-10.2.ebuild,v 1.1 2010/11/15 22:02:51 robbat2 Exp $
+
+EAPI="2"
+DESCRIPTION="3ware SATA+PATA RAID controller Command Line Interface tool"
+HOMEPAGE="http://www.3ware.com/kb/article.aspx?id=14847"
+LICENSE="3ware"
+SLOT="0"
+# binary packages
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+# stripping seems to break this sometimes
+RESTRICT="strip primaryuri"
+# binary packages
+DEPEND=""
+RDEPEND=""
+
+# Upstream has _FUN_ naming these
+# We are mostly prepared for the FreeBSD binaries at this point
+# They just aren't yet enabled here
+PN_KERNEL="${ARCH/*fbsd-*/freebsd}"
+[ "${PN_KERNEL}" != 'freebsd' ] && PN_KERNEL='linux'
+PN_ARCH="${ARCH/*-}"
+PN_ARCH="${PN_ARCH/amd64/x86_64}"
+
+# The naming of <=9.5.0 for freebsd was weird,
+# but 9.5.0.1 has it sanely.
+MY_P="cli_${PN_KERNEL}_${PV}"
+
+# Upstream actually only releases newer versions for new hardware
+# and doesn't release new major versions for old hardware
+# however their backwards compatibility is excellent.
+# I personally test tw_cli on 5 cards:
+# 9550SXU-4LP on amd64
+# 9650SE-{2LP,8LPML} on amd64.
+# 9690SA-{4I,8I} on amd64
+# - Robin H. Johnson <robbat2@gentoo.org> - 15 Nov 2010
+#HW_VARIANT="Escalade7000Series" - for versions 9.3.0.*
+#HW_VARIANT="Escalade9650SE-Series" # for versions 9.4.0*
+#HW_VARIANT="Escalade9690SA-Series" # for versions 9.5.0*
+HW_VARIANT="3ware%20SAS%209750-8i%20Gentoo"
+# package has different tarballs for x86 and amd64
+SRC_URI_BASE="http://www.lsi.com/DistributionSystem/AssetDocument"
+SRC_URI_SUFFIX="?prodName=${HW_VARIANT}"
+SRC_URI_A_linux="cli_linux_${PV}.zip"
+SRC_URI_A_fbsd="cli_freebsd_${PV}.zip"
+SRC_URI_linux="${SRC_URI_BASE}/${SRC_URI_A_linux}${SRC_URI_SUFFIX} -> ${SRC_URI_A_linux}"
+SRC_URI_fbsd="${SRC_URI_BASE}/${SRC_URI_A_fbsd}${SRC_URI_SUFFIX} -> ${SRC_URI_A_fbsd}"
+SRC_URI="kernel_linux? ( ${SRC_URI_linux} )
+ kernel_FreeBSD? ( ${SRC_URI_fbsd} )"
+ #amd64-fbsd? ( ${SRC_URI_amd64_fbsd} )
+SRC_URI_mine="${SRC_URI_BASE}/cli_${PN_KERNEL}_${PV}.zip"
+LICENSE_URL="http://www.lsi.com/lookup/License.aspx?url=${SRC_URI_mine}&prodName=${HW_VARIANT}&subType=Binary&locale="
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${MY_P}.zip
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "PATA: 6xxx, 72xx, 74xx, 78xx, 7000, 7500, 7506"
+ elog "SATA: 8006, 8500, 8506, 9500S, 9550SX, 9590SE,"
+ elog " 9550SXU, 9650SE, 9650SE-{24M8,4LPME},"
+ elog " 9690SA, 9750"
+ elog ""
+ elog "Release notes for this version are available at:"
+ elog "${SRC_URI_BASE}/${PV}_Release_Notes_Web.pdf"
+}
+
+pkg_setup() {
+ supportedcards
+}
+
+pkg_nofetch() {
+ einfo "3ware would like you to agree to the license:"
+ einfo ""
+ einfo "\t${LICENSE_URL}"
+ einfo ""
+ einfo "And then use the following URL to download the"
+ einfo "correct tarballs manually into ${DISTDIR}"
+ einfo ""
+ einfo "Linux - ${SRC_URI_linux}"
+ einfo "FreeBSD - ${SRC_URI_fbsd}"
+ einfo ""
+ einfo "However, they have given permission to redistribute."
+ einfo "http://bugs.gentoo.org/show_bug.cgi?id=60690#c106"
+ einfo ""
+ supportedcards
+}
+
+src_install() {
+ into /
+ dosbin ${PN_ARCH}/tw_cli
+ into /usr
+ # 10.2 is missing this
+ if [[ -f tw_cli.8.nroff ]]; then
+ newman tw_cli.8.nroff tw_cli.8
+ else
+ ewarn "Upstream's 10.2 release is missing the tw_cli manpage."
+ fi
+ dohtml *.html
+}