summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Longland <redhatter@gentoo.org>2006-03-25 15:57:58 +0000
committerStuart Longland <redhatter@gentoo.org>2006-03-25 15:57:58 +0000
commit32a7764e10a1b803e2925de4096c208c1ffec9f9 (patch)
tree7c7cfcfeafbf9ecda7b06679933f2317548409c0 /sys-boot/colo
parentMark 3.4.3 stable on ia64 (diff)
downloadgentoo-2-32a7764e10a1b803e2925de4096c208c1ffec9f9.tar.gz
gentoo-2-32a7764e10a1b803e2925de4096c208c1ffec9f9.tar.bz2
gentoo-2-32a7764e10a1b803e2925de4096c208c1ffec9f9.zip
Removed old 1.16 ebuild. Added 1.21 as new unstable release.
(Portage version: 2.0.54)
Diffstat (limited to 'sys-boot/colo')
-rw-r--r--sys-boot/colo/ChangeLog9
-rw-r--r--sys-boot/colo/colo-1.21.ebuild109
-rw-r--r--sys-boot/colo/files/digest-colo-1.161
-rw-r--r--sys-boot/colo/files/digest-colo-1.211
4 files changed, 117 insertions, 3 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index dc448096932b..9717a27bfd38 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/colo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.15 2005/12/07 07:33:43 redhatter Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.16 2006/03/25 15:57:58 redhatter Exp $
+
+*colo-1.21 (25 Mar 2006)
+
+ 25 Mar 2006; Stuart Longland <redhatter@gentoo.org> +colo-1.21.ebuild:
+ Removed old 1.16 ebuild. Added 1.21 as new unstable release.
07 Dec 2005; Stuart Longland <redhatter@gentoo.org>
-files/colo-linker-overlap-fix.patch, +files/menu.colo,
diff --git a/sys-boot/colo/colo-1.21.ebuild b/sys-boot/colo/colo-1.21.ebuild
new file mode 100644
index 000000000000..32f33d26bc90
--- /dev/null
+++ b/sys-boot/colo/colo-1.21.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.21.ebuild,v 1.1 2006/03/25 15:57:58 redhatter Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt LOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building the CoLo Bootloader ..."
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell,netcon} tools/README.tools TODO
+
+ # all tools except lcdtools (see below)
+ local tool
+ for tool in flash-tool colo-perm copy-rom elf2rfx; do
+
+ einfo "Installing ${tool} binary to ${D}/usr/sbin"
+ dosbin tools/${tool}/${tool}
+ if [ -f tools/${tool}/${tool}.8 ]; then
+ einfo "Installing ${tool} manpage to ${D}/usr/share/man"
+ doman tools/flash-tool/flash-tool.8
+ fi
+
+ done
+
+ # lcdtools
+ for tool in paneld putlcd e2fsck-lcd; do
+ einfo "Installing ${tool} binary and manpage to ${D}/usr/sbin"
+ dosbin tools/lcdtools/${tool}/${tool}
+ doman tools/lcdtools/${tool}/${tool}.8
+ done
+ dolib.a tools/lcdtools/liblcd/liblcd.a
+
+ # bootscripts
+ dodir /usr/lib/colo/scripts
+ cp ${FILESDIR}/*.colo ${D}/usr/lib/colo/scripts
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Install locations:"
+ einfo " Binaries:\t/usr/lib/${PN}"
+ einfo " Docs:\t/usr/share/doc/${PF}"
+ einfo " Tools:\t/usr/sbin/{flash-tool,colo-perm,copy-rom,"
+ einfo " \tputlcd,paneld,e2fsck-lcd,elf2rfx}"
+ einfo " Scripts:\t/usr/lib/${PN}/scripts"
+ echo -e ""
+ einfo "Please read the docs to fully understand the behavior of this bootloader, and"
+ einfo "edit the boot scripts to suit your needs."
+ echo -e ""
+ ewarn "Users installing ${PN} for the first time need to be aware that newer"
+ ewarn "versions of ${PN} disable the serial port by default. If the serial port"
+ ewarn "is needed, select it from the boot menu. Users using the example boot"
+ ewarn "scripts provided will have the serial port automatically enabled."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/digest-colo-1.16 b/sys-boot/colo/files/digest-colo-1.16
deleted file mode 100644
index 9bdd764a236b..000000000000
--- a/sys-boot/colo/files/digest-colo-1.16
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7e00fb1a68e185c03152dc161cecb8d4 colo-1.16.tar.gz 242604
diff --git a/sys-boot/colo/files/digest-colo-1.21 b/sys-boot/colo/files/digest-colo-1.21
new file mode 100644
index 000000000000..dd18a6fee136
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.21
@@ -0,0 +1 @@
+MD5 9d8a37ad4984ec6660ff159e83f15404 colo-1.21.tar.gz 255205