summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-20 02:51:32 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-20 02:51:32 +0000
commitd5139ef672acb39a224144a9309c062cf94853a6 (patch)
treef7cc5f9050099789489e330ab2abcf09472212c0 /sys-boot/efibootmgr
parentI hate blank spaces in output for no reason, so switching from using echo to ... (diff)
downloadgentoo-2-d5139ef672acb39a224144a9309c062cf94853a6.tar.gz
gentoo-2-d5139ef672acb39a224144a9309c062cf94853a6.tar.bz2
gentoo-2-d5139ef672acb39a224144a9309c062cf94853a6.zip
old
Diffstat (limited to 'sys-boot/efibootmgr')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild41
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.0.ebuild33
-rw-r--r--sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch10
3 files changed, 0 insertions, 84 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild b/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild
deleted file mode 100644
index 087bf2f7f9b1..000000000000
--- a/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild,v 1.5 2004/07/01 21:45:43 eradicator Exp $
-
-inherit eutils
-
-DESCRIPTION="Interact with the EFI Boot Manager on IA-64 Systems"
-HOMEPAGE="http://developer.intel.com/technology/efi"
-
-# This is efibootmgr, a Linux user-space application to modify the
-# Intel Extensible Firmware Interface (EFI) Boot Manager. This
-# application can create and destroy boot entries, change the boot
-# order, change the next running boot option, and more.
-#
-# Note: efibootmgr requires that the kernel module efivars be loaded
-# prior to use. `modprobe efivars` should do the trick.
-
-SRC_URI="http://domsch.com/linux/ia64/${PN}/${P}.tar.gz"
-KEYWORDS="ia64"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND="virtual/libc" # don't think there's anything else
-RDEPEND="virtual/libc"
-
-src_unpack() {
- unpack ${A} && cd ${S} || die "failed to unpack"
- epatch ${FILESDIR}/efibootmgr-0.4.1-makefile.patch || die "epatch failed"
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- mkdir -p ${D}/usr/sbin
- install -m755 src/efibootmgr/efibootmgr ${D}/usr/sbin
- doman src/man/man8/efibootmgr.8
- dodoc AUTHORS COPYING README doc/ChangeLog doc/TODO
-}
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.0.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.0.ebuild
deleted file mode 100644
index 0b1875c1fc4c..000000000000
--- a/sys-boot/efibootmgr/efibootmgr-0.5.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.5.0.ebuild,v 1.3 2005/02/05 19:56:48 plasmaroo Exp $
-
-inherit eutils
-
-DESCRIPTION="Interact with the EFI Boot Manager on IA-64 Systems"
-HOMEPAGE="http://developer.intel.com/technology/efi"
-SRC_URI="http://linux.dell.com/efibootmgr/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ia64"
-IUSE=""
-
-DEPEND="virtual/libc
- sys-apps/pciutils"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/efibootmgr-0.4.1-makefile.patch
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- dosbin src/efibootmgr/efibootmgr || die
- doman src/man/man8/efibootmgr.8
- dodoc AUTHORS README doc/ChangeLog doc/TODO
-}
diff --git a/sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch b/sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch
deleted file mode 100644
index 4a9b0f9c1c18..000000000000
--- a/sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- efibootmgr-0.4.1/Makefile.makefile 2002-10-22 22:45:30.000000000 +0200
-+++ efibootmgr-0.4.1/Makefile 2003-05-26 15:09:58.000000000 +0200
-@@ -9,6 +9,7 @@
- RELEASE_STRING := $(RELEASE_NAME)-$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)
-
- CFLAGS += -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)\" -Wall
-+ CFLAGS += $(shell if $(CC) -fno-merge-constants -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-fno-merge-constants"; fi)
-
- MODULES := src
-