summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-04 18:46:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-04 18:46:05 +0000
commitd5cc094a2f7814655479fc677c6e7bec5e12a4c1 (patch)
treee6c0296aa86b75cfd710a6fe01a6e76cc7024c82 /sys-boot/grub
parentMarking gnome-build-2.24.1 ~ppc64 for bug 268359 (diff)
downloadgentoo-2-d5cc094a2f7814655479fc677c6e7bec5e12a4c1.tar.gz
gentoo-2-d5cc094a2f7814655479fc677c6e7bec5e12a4c1.tar.bz2
gentoo-2-d5cc094a2f7814655479fc677c6e7bec5e12a4c1.zip
Bug #255271: check for IA32_EMULATION on 64-bit, as we are building a 32-bit binary and need to be able to run it.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-0.97-r9.ebuild11
2 files changed, 14 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 8eda6c822d2f..90a2805005bf 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.120 2009/06/20 12:43:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.121 2009/07/04 18:46:05 robbat2 Exp $
+
+ 04 Jul 2009; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r9.ebuild:
+ Bug #255271: check for IA32_EMULATION on 64-bit, as we are building a
+ 32-bit binary and need to be able to run it.
20 Jun 2009; Mike Frysinger <vapier@gentoo.org> grub-9999.ebuild:
Enable efi/mkfont/pe2elf code and add USE=debug #273896 by John Christian
diff --git a/sys-boot/grub/grub-0.97-r9.ebuild b/sys-boot/grub/grub-0.97-r9.ebuild
index 38007c02d20a..f09ef27b85f0 100644
--- a/sys-boot/grub/grub-0.97-r9.ebuild
+++ b/sys-boot/grub/grub-0.97-r9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r9.ebuild,v 1.4 2009/05/15 21:11:24 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r9.ebuild,v 1.5 2009/07/04 18:46:05 robbat2 Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
# we never updated any of the source code (it still all wants menu.lst),
# and there is no indication that upstream is making the transition.
-inherit mount-boot eutils flag-o-matic toolchain-funcs autotools
+inherit mount-boot eutils flag-o-matic toolchain-funcs autotools linux-info
PATCHVER="1.9" # Should match the revision ideally
DESCRIPTION="GNU GRUB Legacy boot loader"
@@ -28,6 +28,13 @@ DEPEND="ncurses? (
)"
PROVIDE="virtual/bootloader"
+pkg_setup() {
+ local arch="$(tc-arch)"
+ case ${arch} in
+ amd64) CONFIG_CHECK='~IA32_EMULATION' check_extra_config ;;
+ esac
+}
+
src_unpack() {
unpack ${A}
cd "${S}"