summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2013-04-07 08:42:42 +0000
committerJonathan Callen <abcd@gentoo.org>2013-04-07 08:42:42 +0000
commitb62123dc0fb0f17cb975abedd895c946dec23738 (patch)
treeaeffd6cfa257b7ac28b5b50ae88dafa79aed1b0f /sys-boot/os-prober
parentImprove compiler check (#463704 by Alphat-PC), drop old. (diff)
downloadgentoo-2-b62123dc0fb0f17cb975abedd895c946dec23738.tar.gz
gentoo-2-b62123dc0fb0f17cb975abedd895c946dec23738.tar.bz2
gentoo-2-b62123dc0fb0f17cb975abedd895c946dec23738.zip
Replace calls to grub-mount with grub2-mount, as we rename it in Gentoo (to allow parallel installation of grub:0)
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 229E5838)
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/ChangeLog8
-rw-r--r--sys-boot/os-prober/os-prober-1.57-r1.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index 1e8e72fc53a0..fa1a4a184236 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/os-prober
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.17 2013/03/17 16:14:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.18 2013/04/07 08:42:42 abcd Exp $
+
+*os-prober-1.57-r1 (07 Apr 2013)
+
+ 07 Apr 2013; Jonathan Callen <abcd@gentoo.org> +os-prober-1.57-r1.ebuild:
+ Replace calls to grub-mount with grub2-mount, as we rename it in Gentoo (to
+ allow parallel installation of grub:0)
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/sys-boot/os-prober/os-prober-1.57-r1.ebuild b/sys-boot/os-prober/os-prober-1.57-r1.ebuild
new file mode 100644
index 000000000000..65749671904e
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.57-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.57-r1.ebuild,v 1.1 2013/04/07 08:42:42 abcd Exp $
+
+EAPI=5
+
+#inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # use default GNU rules
+ rm Makefile || die 'rm Makefile failed'
+ # Fix references to grub-mount
+ sed -i -e 's:grub-mount:grub2-mount:g' \
+ common.sh \
+ linux-boot-probes/common/50mounted-tests \
+ os-probes/common/50mounted-tests
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}