summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-03-26 19:08:53 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-03-26 19:08:53 +0000
commit932c79e470fa822af02df9d31ee718a2b12779e8 (patch)
treece3a699842004e3b5675fbe8634707c7a17499e4 /sys-boot/palo
parentAdding alpha keyword...bug submitter reported running successfully. (Manifest... (diff)
downloadgentoo-2-932c79e470fa822af02df9d31ee718a2b12779e8.tar.gz
gentoo-2-932c79e470fa822af02df9d31ee718a2b12779e8.tar.bz2
gentoo-2-932c79e470fa822af02df9d31ee718a2b12779e8.zip
Version bump.
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/ChangeLog7
-rw-r--r--sys-boot/palo/Manifest2
-rw-r--r--sys-boot/palo/files/digest-palo-1.3_pre200403031
-rw-r--r--sys-boot/palo/palo-1.3_pre20040303.ebuild41
4 files changed, 50 insertions, 1 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index b83bb05d952f..9bd9bd71ff5d 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.3 2004/01/08 13:46:33 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.4 2004/03/26 19:08:53 gmsoft Exp $
+
+*palo-1.3_pre20040303 (26 Mar 2004)
+
+ 26 Mar 2004; Guy Martin <gmsoft@gentoo.org> palo-1.3_pre20040303.ebuild :
+ Version bump.
*palo-1.2_pre20030630 (01 Jul 2003)
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index f9d8a72d2ef4..e0fdbced1ee0 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -2,6 +2,8 @@ MD5 cb0d277451f525cd7778966677336c7b ChangeLog 1606
MD5 9eb3e7bb4ebac420842bd3e90dbf8726 metadata.xml 218
MD5 390b42e7302b14f706016c527973ab99 palo-1.2_pre20030115.ebuild 959
MD5 12faa444c908eddbfe4f6da94ed83f51 palo-1.2_pre20030630.ebuild 972
+MD5 12faa444c908eddbfe4f6da94ed83f51 palo-1.3_pre20040303.ebuild 972
MD5 148ea82d5c29fd7d4822d57c72e8db0a files/digest-palo-1.2_pre20030115 71
MD5 7ee737710bef1fd5dd94d975eaf30721 files/digest-palo-1.2_pre20030630 71
MD5 ad8b81577ffd8be90930cf8e02211313 files/palo.conf 214
+MD5 976dc147179cc0e2e54c219e32084c2c files/digest-palo-1.3_pre20040303 71
diff --git a/sys-boot/palo/files/digest-palo-1.3_pre20040303 b/sys-boot/palo/files/digest-palo-1.3_pre20040303
new file mode 100644
index 000000000000..5c97109fbcc7
--- /dev/null
+++ b/sys-boot/palo/files/digest-palo-1.3_pre20040303
@@ -0,0 +1 @@
+MD5 05f2ede2b20690c50e5e245babd40601 palo-1.3-CVS20040303.tar.gz 99700
diff --git a/sys-boot/palo/palo-1.3_pre20040303.ebuild b/sys-boot/palo/palo-1.3_pre20040303.ebuild
new file mode 100644
index 000000000000..27d003a00521
--- /dev/null
+++ b/sys-boot/palo/palo-1.3_pre20040303.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.3_pre20040303.ebuild,v 1.1 2004/03/26 19:08:53 gmsoft Exp $
+
+MY_V=${PV/_pre/-CVS}
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://ftp.parisc-linux.org/cvs/palo-${MY_V}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+S=${WORKDIR}/palo
+
+#Compile only on hppa stations
+KEYWORDS="~hppa -*"
+IUSE=""
+
+PROVIDE="virtual/bootloader"
+
+DEPEND=">=glibc-2.2.4"
+
+src_compile() {
+ emake -C palo CFLAGS="${CFLAGS} -I../include -I../lib" || die
+ emake -C ipl CFLAGS="${CFLAGS} -I. -I../lib -I../include -fwritable-strings -mdisable-fpregs -Wall" || die
+ emake MACHINE=parisc iplboot
+ emake || die
+}
+
+src_install() {
+ dosbin palo/palo
+ doman palo.8
+ dohtml README.html
+ dodoc README
+ dodoc palo.conf
+
+ insinto /etc
+ doins ${FILESDIR}/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+}