summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-02 17:51:13 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-02 17:51:13 +0000
commit9ce9e3455df85c026409ee87987a4a9e8621fa41 (patch)
treea4fc9c8033b7285d411709b24149982dbd336c71 /sys-boot/palo
parentVersion bump (diff)
downloadgentoo-2-9ce9e3455df85c026409ee87987a4a9e8621fa41.tar.gz
gentoo-2-9ce9e3455df85c026409ee87987a4a9e8621fa41.tar.bz2
gentoo-2-9ce9e3455df85c026409ee87987a4a9e8621fa41.zip
Version bump. Remove empty DEPEND.
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'sys-boot/palo')
-rw-r--r--sys-boot/palo/ChangeLog7
-rw-r--r--sys-boot/palo/palo-1.18.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index fb722725bb24..6aeefc785d14 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.26 2010/07/13 01:56:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.27 2010/10/02 17:51:13 jer Exp $
+
+*palo-1.18 (02 Oct 2010)
+
+ 02 Oct 2010; Jeroen Roovers <jer@gentoo.org> +palo-1.18.ebuild:
+ Version bump. Remove empty DEPEND.
13 Jul 2010; Jeroen Roovers <jer@gentoo.org> -palo-1.16_p1.ebuild,
palo-1.17.ebuild:
diff --git a/sys-boot/palo/palo-1.18.ebuild b/sys-boot/palo/palo-1.18.ebuild
new file mode 100644
index 000000000000..72a587806c7d
--- /dev/null
+++ b/sys-boot/palo/palo-1.18.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.18.ebuild,v 1.1 2010/10/02 17:51:13 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ http://packages.qa.debian.org/p/palo.html"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+PROVIDE="virtual/bootloader"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-remove-HOME-TERM.patch \
+ "${FILESDIR}"/${PN}-1.16_p1-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake -C palo || die "make palo failed"
+ emake -C ipl || die "make ipl failed"
+ emake MACHINE=parisc iplboot || die "make iplboot failed"
+}
+
+src_install() {
+ into /
+ dosbin palo/palo || die
+
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf || die
+
+ insinto /usr/share/palo
+ doins iplboot || die
+}