summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFriedrich Oslage <bluebird@gentoo.org>2008-06-12 20:33:52 +0000
committerFriedrich Oslage <bluebird@gentoo.org>2008-06-12 20:33:52 +0000
commitaae055ca10b63a5df3aad2af2bd97bc307d84d60 (patch)
treef9fe84169bfa84588a48d74fa6bfc89c46071e4b /sys-boot/silo
parentMarking libvorbis-1.2.1_rc1 ppc64 for bug 222085 (diff)
downloadgentoo-2-aae055ca10b63a5df3aad2af2bd97bc307d84d60.tar.gz
gentoo-2-aae055ca10b63a5df3aad2af2bd97bc307d84d60.tar.bz2
gentoo-2-aae055ca10b63a5df3aad2af2bd97bc307d84d60.zip
Add a patch to make it work with gcc 4.3
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/ChangeLog7
-rw-r--r--sys-boot/silo/files/gcc-4.3-compile.patch20
-rw-r--r--sys-boot/silo/silo-1.4.13-r1.ebuild5
-rw-r--r--sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild5
4 files changed, 34 insertions, 3 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 9cdb41b0dc71..6ceedaf63bd0 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.38 2008/05/15 16:33:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.39 2008/06/12 20:33:51 bluebird Exp $
+
+ 12 Jun 2008; Friedrich Oslage <bluebird@gentoo.org>
+ +files/gcc-4.3-compile.patch, silo-1.4.13-r1.ebuild,
+ silo-1.4.13a_pre20070930_p2.ebuild:
+ Add a patch to make it work with gcc 4.3
15 May 2008; Raúl Porcel <armin76@gentoo.org> metadata.xml:
Fix metadata
diff --git a/sys-boot/silo/files/gcc-4.3-compile.patch b/sys-boot/silo/files/gcc-4.3-compile.patch
new file mode 100644
index 000000000000..74c37558553e
--- /dev/null
+++ b/sys-boot/silo/files/gcc-4.3-compile.patch
@@ -0,0 +1,20 @@
+--- silo.orig/second/Makefile
++++ silo/second/Makefile
+@@ -58,13 +58,13 @@
+ $(AR) rc $@ $(FS_OBJS)
+
+ second: $(OBJS) mark.o
+- $(LD) $(LDFLAGS_SMALL) -Bstatic -o second $(OBJS) -lext2fs mark.o
+- $(LD) $(LDFLAGS_LARGE) -Bstatic -o second2 $(OBJS) -lext2fs mark.o
++ $(LD) $(LDFLAGS_SMALL) -Bstatic -o second $(OBJS) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
++ $(LD) $(LDFLAGS_LARGE) -Bstatic -o second2 $(OBJS) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
+ $(NM) second | grep -v '*ABS*' | sort > second.map
+
+ silotftp: $(OBJSNET) mark.o
+- $(LD) $(LDFLAGS_SMALL) -Bstatic -o silotftp $(OBJSNET) -lext2fs mark.o
+- $(LD) $(LDFLAGS_LARGE) -Bstatic -o silotftp2 $(OBJSNET) -lext2fs mark.o
++ $(LD) $(LDFLAGS_SMALL) -Bstatic -o silotftp $(OBJSNET) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
++ $(LD) $(LDFLAGS_LARGE) -Bstatic -o silotftp2 $(OBJSNET) -lext2fs mark.o `$(CC) -print-libgcc-file-name`
+ $(NM) silotftp | grep -v '*ABS*' | sort > silotftp.map
+
+ second.l: second
diff --git a/sys-boot/silo/silo-1.4.13-r1.ebuild b/sys-boot/silo/silo-1.4.13-r1.ebuild
index 620ef8851cdb..f071edd6d3d1 100644
--- a/sys-boot/silo/silo-1.4.13-r1.ebuild
+++ b/sys-boot/silo/silo-1.4.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13-r1.ebuild,v 1.2 2008/05/15 15:00:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13-r1.ebuild,v 1.3 2008/06/12 20:33:51 bluebird Exp $
inherit mount-boot flag-o-matic toolchain-funcs
@@ -24,6 +24,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/silo-1.4.x-noglibc_time.patch
+
+ # make it compile with gcc 4.3
+ epatch "${FILESDIR}"/gcc-4.3-compile.patch
}
src_compile() {
diff --git a/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild b/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild
index a905333d0d93..5f9ddfe0b813 100644
--- a/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild
+++ b/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild,v 1.1 2008/05/15 15:00:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13a_pre20070930_p2.ebuild,v 1.2 2008/06/12 20:33:51 bluebird Exp $
inherit mount-boot flag-o-matic toolchain-funcs
@@ -38,6 +38,9 @@ src_unpack() {
epatch "${WORKDIR}"/${MY_P/_/-}/debian/patches/*.patch
epatch "${FILESDIR}"/sanitized-linuxheaders.patch
+ # make it compile with gcc 4.3
+ epatch "${FILESDIR}"/gcc-4.3-compile.patch
+
#Set the correct version
sed -i -e "s/1.4.13/1.4.13_git20070830_p2/g" Rules.make
}