summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-17 04:09:05 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-17 04:09:05 +0000
commit032314016b2485f138c3e0e1d3af113ff5f4d9d9 (patch)
tree1ada71f00154083f6363c2bdf7eaa717e2c7e7ad /sys-boot
parentUpdate to EAPI=5. (diff)
downloadgentoo-2-032314016b2485f138c3e0e1d3af113ff5f4d9d9.tar.gz
gentoo-2-032314016b2485f138c3e0e1d3af113ff5f4d9d9.tar.bz2
gentoo-2-032314016b2485f138c3e0e1d3af113ff5f4d9d9.zip
Switch `export -n` to `unset`, and also clear CPPFLAGS & LDFLAGS.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/yaboot/ChangeLog9
-rw-r--r--sys-boot/yaboot/yaboot-1.3.14-r2.ebuild7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.16.ebuild7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r1.ebuild57
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild7
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17.ebuild50
6 files changed, 16 insertions, 121 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 71a2dd9084d0..2d56d0d55691 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/yaboot
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.44 2012/06/20 13:54:25 josejx Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.45 2015/05/17 04:09:05 vapier Exp $
+
+ 17 May 2015; Mike Frysinger <vapier@gentoo.org> -yaboot-1.3.17-r1.ebuild,
+ -yaboot-1.3.17.ebuild, yaboot-1.3.14-r2.ebuild, yaboot-1.3.16.ebuild,
+ yaboot-1.3.17-r2.ebuild:
+ Switch `export -n` to `unset`, and also clear CPPFLAGS & LDFLAGS.
20 Jun 2012; Joseph Jezak <josejx@gentoo.org> yaboot-1.3.17-r2.ebuild,
files/yaboot-stubfuncs.patch:
diff --git a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
index af1461d9f135..3d452c60c35f 100644
--- a/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.4 2011/04/10 14:23:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.14-r2.ebuild,v 1.5 2015/05/17 04:09:05 vapier Exp $
inherit eutils toolchain-funcs
@@ -18,8 +18,7 @@ RDEPEND="!ibm? ( sys-fs/hfsutils
sys-fs/mac-fdisk )"
src_compile() {
- export -n CFLAGS
- export -n CXXFLAGS
+ unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
[ -n "$(tc-getCC)" ] || CC="gcc"
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
diff --git a/sys-boot/yaboot/yaboot-1.3.16.ebuild b/sys-boot/yaboot/yaboot-1.3.16.ebuild
index ec8c6f02361d..05b25ddd2f62 100644
--- a/sys-boot/yaboot/yaboot-1.3.16.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.5 2011/05/22 07:48:57 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.16.ebuild,v 1.6 2015/05/17 04:09:05 vapier Exp $
inherit eutils toolchain-funcs
@@ -37,8 +37,7 @@ src_unpack() {
}
src_compile() {
- export -n CFLAGS
- export -n CXXFLAGS
+ unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
[ -n "$(tc-getCC)" ] || CC="gcc"
emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
}
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r1.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r1.ebuild
deleted file mode 100644
index 8cf06536b7c1..000000000000
--- a/sys-boot/yaboot/yaboot-1.3.17-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r1.ebuild,v 1.3 2012/05/15 15:17:48 josejx Exp $
-
-EAPI=2
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="PPC Bootloader"
-SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
-HOMEPAGE="http://yaboot.ozlabs.org"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="-* ppc -ppc64"
-IUSE="ibm"
-
-DEPEND="sys-apps/powerpc-utils
- sys-fs/e2fsprogs[static-libs]"
-RDEPEND="!ibm? ( sys-fs/hfsutils
- sys-fs/hfsplusutils
- sys-fs/mac-fdisk )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp "${FILESDIR}/new-ofpath" "${S}/ybin/ofpath"
-}
-
-src_prepare() {
- # dual boot patch
- epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
- epatch "${FILESDIR}/chrpfix.patch"
- if [[ "$(gcc-major-version)" -eq "3" ]]; then
- epatch "${FILESDIR}/${PN}-nopiessp.patch"
- fi
- if [[ "$(gcc-major-version)" -eq "4" ]]; then
- epatch "${FILESDIR}/${P}-nopiessp-gcc4.patch"
- fi
-
- # Error only on real errors, for prom printing format compile failure
- sed -i "s:-Werror:-Wno-error:g" Makefile
-
- epatch "${FILESDIR}/${PN}-stubfuncs.patch"
-}
-
-src_compile() {
- export -n CFLAGS
- export -n CXXFLAGS
- [ -n "$(tc-getCC)" ] || CC="gcc"
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
-}
-
-src_install() {
- sed -i -e 's/\/local//' etc/yaboot.conf
- make ROOT="${D}" PREFIX=/usr MANDIR=share/man install || die
- mv "${D}/etc/yaboot.conf" "${D}/etc/yaboot.conf.sample"
-}
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index b499e2de1cd0..9c08768e3586 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.2 2012/06/20 13:54:25 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.3 2015/05/17 04:09:05 vapier Exp $
EAPI=2
@@ -48,8 +48,7 @@ src_prepare() {
}
src_compile() {
- export -n CFLAGS
- export -n CXXFLAGS
+ unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
[ -n "$(tc-getCC)" ] || CC="gcc"
emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
}
diff --git a/sys-boot/yaboot/yaboot-1.3.17.ebuild b/sys-boot/yaboot/yaboot-1.3.17.ebuild
deleted file mode 100644
index 1fac8bba0e1b..000000000000
--- a/sys-boot/yaboot/yaboot-1.3.17.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17.ebuild,v 1.1 2012/02/24 15:15:33 josejx Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="PPC Bootloader"
-SRC_URI="http://yaboot.ozlabs.org/releases/${P}.tar.gz"
-HOMEPAGE="http://yaboot.ozlabs.org"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="-* ~ppc -ppc64"
-IUSE="ibm"
-
-DEPEND="sys-apps/powerpc-utils"
-RDEPEND="!ibm? ( sys-fs/hfsutils
- sys-fs/hfsplusutils
- sys-fs/mac-fdisk )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp "${FILESDIR}/new-ofpath" "${S}/ybin/ofpath"
-
- # dual boot patch
- epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
- epatch "${FILESDIR}/chrpfix.patch"
- if [[ "$(gcc-major-version)" -eq "3" ]]; then
- epatch "${FILESDIR}/${PN}-nopiessp.patch"
- fi
- if [[ "$(gcc-major-version)" -eq "4" ]]; then
- epatch "${FILESDIR}/${P}-nopiessp-gcc4.patch"
- fi
-
- # Error only on real errors, for prom printing format compile failure
- sed -i "s:-Werror:-Wno-error:g" Makefile
-}
-
-src_compile() {
- export -n CFLAGS
- export -n CXXFLAGS
- [ -n "$(tc-getCC)" ] || CC="gcc"
- emake PREFIX=/usr MANDIR=share/man CC="$(tc-getCC)" || die
-}
-
-src_install() {
- sed -i -e 's/\/local//' etc/yaboot.conf
- make ROOT="${D}" PREFIX=/usr MANDIR=share/man install || die
- mv "${D}/etc/yaboot.conf" "${D}/etc/yaboot.conf.sample"
-}