summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-04-22 15:14:56 +0000
committerJeroen Roovers <jer@gentoo.org>2014-04-22 15:14:56 +0000
commit101082946f89de48edd6b32f21b2c2b632e71509 (patch)
tree6e31ac05c3860250a29f9c9e93ea979ea0495cf4 /sys-boot
parentVersion bump. (diff)
downloadgentoo-2-101082946f89de48edd6b32f21b2c2b632e71509.tar.gz
gentoo-2-101082946f89de48edd6b32f21b2c2b632e71509.tar.bz2
gentoo-2-101082946f89de48edd6b32f21b2c2b632e71509.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog9
-rw-r--r--sys-boot/unetbootin/unetbootin-603.ebuild90
2 files changed, 97 insertions, 2 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index be8bfd7d5d94..2b73a4990878 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.103 2013/09/30 21:25:35 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.104 2014/04/22 15:14:55 jer Exp $
+
+*unetbootin-603 (22 Apr 2014)
+
+ 22 Apr 2014; Jeroen Roovers <jer@gentoo.org> +unetbootin-603.ebuild:
+ Version bump.
30 Sep 2013; Jeroen Roovers <jer@gentoo.org> -unetbootin-583.ebuild,
-unetbootin-584.ebuild:
diff --git a/sys-boot/unetbootin/unetbootin-603.ebuild b/sys-boot/unetbootin/unetbootin-603.ebuild
new file mode 100644
index 000000000000..0c5f1e925c41
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-603.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-603.ebuild,v 1.1 2014/04/22 15:14:56 jer Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S="${WORKDIR}"
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="
+ ${DEPEND}
+ sys-fs/mtools
+ <sys-boot/syslinux-5
+ app-arch/p7zip
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-581-desktop.patch"
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Make room between the last line of TRANSLATIONS and the next definition
+ sed -i \
+ -e '/^DEFINES/s|.*|\n&|g' \
+ ${PN}.pro || die
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+}
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}