summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-12-17 20:20:29 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-12-17 20:20:29 +0000
commit6fbc9fe467a2258bcb23cbb0e83f5ea014a057a7 (patch)
tree0e5af95ee4910fe414e09c457b990524e6f26bb0 /sys-boot
parentAdded ~ppc64; bug #97355 (diff)
downloadgentoo-2-6fbc9fe467a2258bcb23cbb0e83f5ea014a057a7.tar.gz
gentoo-2-6fbc9fe467a2258bcb23cbb0e83f5ea014a057a7.tar.bz2
gentoo-2-6fbc9fe467a2258bcb23cbb0e83f5ea014a057a7.zip
Fix gcc-3.4 compilation, bug 115337.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/aboot/ChangeLog6
-rw-r--r--sys-boot/aboot/aboot-1.0_pre20040408.ebuild5
-rw-r--r--sys-boot/aboot/files/aboot-gcc-3.4.patch31
3 files changed, 40 insertions, 2 deletions
diff --git a/sys-boot/aboot/ChangeLog b/sys-boot/aboot/ChangeLog
index 332dde64a475..6e82c73075e3 100644
--- a/sys-boot/aboot/ChangeLog
+++ b/sys-boot/aboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/aboot
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.7 2005/03/01 23:06:36 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/ChangeLog,v 1.8 2005/12/17 20:20:29 kloeri Exp $
+
+ 17 Dec 2005; Bryan Østergaard <kloeri@gentoo.org
+ +files/aboot-gcc-3.4.patch, aboot-1.0_pre20040408.ebuild:
+ Fix gcc-3.4 compilation, bug 115337.
02 Mar 2005; Bryan Østergaard <kloeri@gentoo.org>
aboot-1.0_pre20040408.ebuild:
diff --git a/sys-boot/aboot/aboot-1.0_pre20040408.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
index 3f2f08d1a735..ceeeafadbf8d 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/aboot-1.0_pre20040408.ebuild,v 1.5 2005/03/01 23:06:36 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/aboot/aboot-1.0_pre20040408.ebuild,v 1.6 2005/12/17 20:20:29 kloeri Exp $
+
+inherit eutils
DESCRIPTION="Alpha Linux boot loader for SRM"
HOMEPAGE="http://aboot.sourceforge.net/"
@@ -18,6 +20,7 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i "s:/usr/man:/usr/share/man:" Makefile || die
+ epatch "${FILESDIR}/aboot-gcc-3.4.patch"
}
src_compile() {
diff --git a/sys-boot/aboot/files/aboot-gcc-3.4.patch b/sys-boot/aboot/files/aboot-gcc-3.4.patch
new file mode 100644
index 000000000000..24da18ce8190
--- /dev/null
+++ b/sys-boot/aboot/files/aboot-gcc-3.4.patch
@@ -0,0 +1,31 @@
+--- aboot-1.0_pre20040408/cons.c
++++ aboot-1.0_pre20040408/cons.c
+@@ -20,7 +20,6 @@
+ #endif
+
+ long cons_dev; /* console device */
+-extern long int dispatch(); /* Need the full 64 bit return here...*/
+
+ long
+ cons_puts(const char *str, long len)
+--- aboot-1.0_pre20040408/fs/ext2.c
++++ aboot-1.0_pre20040408/fs/ext2.c
+@@ -6,6 +6,7 @@
+ * This file has been ported from the DEC 32-bit Linux version
+ * by David Mosberger (davidm@cs.arizona.edu).
+ */
++#include <string.h>
+ #include <linux/stat.h>
+ #include <linux/types.h>
+ #include <linux/version.h>
+--- aboot-1.0_pre20040408/include/cons.h
++++ aboot-1.0_pre20040408/include/cons.h
+@@ -3,7 +3,7 @@
+
+ extern long cons_dev; /* console device */
+
+-extern long dispatch(long proc, ...);
++extern long int dispatch(long proc, ...);
+
+ #ifdef TESTING
+ #define STRINGIFY(sym) #sym