summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2006-05-30 20:14:37 +0000
committerGuy Martin <gmsoft@gentoo.org>2006-05-30 20:14:37 +0000
commit886eae10e0ebdc4205001754376590eacaaab88b (patch)
treef9016ec9df5801b497d5a0f2282208286d336026 /sys-boot
parentInitial import, closes bug #100189 (diff)
downloadgentoo-2-886eae10e0ebdc4205001754376590eacaaab88b.tar.gz
gentoo-2-886eae10e0ebdc4205001754376590eacaaab88b.tar.bz2
gentoo-2-886eae10e0ebdc4205001754376590eacaaab88b.zip
Version bump. Fix compilation with gcc-4.1.1.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/ChangeLog7
-rw-r--r--sys-boot/palo/Manifest2
-rw-r--r--sys-boot/palo/files/digest-palo-1.14_pre200604091
-rw-r--r--sys-boot/palo/palo-1.14_pre20060409.ebuild44
4 files changed, 53 insertions, 1 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index 4e7267fee97b..90926c42a2d3 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.15 2006/02/09 09:41:08 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.16 2006/05/30 20:14:37 gmsoft Exp $
+
+*palo-1.14_pre20060409 (30 May 2006)
+
+ 30 May 2006; Guy Martin <gmsoft@gentoo.org> +palo-1.14_pre20060409.ebuild:
+ Version bump. Fix compilation with gcc-4.1.1.
*palo-1.13_pre20060123 (09 Feb 2006)
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 7ec99ce9367c..27ca31fd5e48 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1,6 +1,7 @@
MD5 34211d99ae18e0612d21768226154f3c ChangeLog 3083
MD5 ac935ddd89e26083054622394617a13a files/digest-palo-1.10_pre20051012 72
MD5 ad0b999bc275cade72f621143fdadba5 files/digest-palo-1.13_pre20060123 72
+MD5 681194de657c51d0d86e0b0133bae372 files/digest-palo-1.14_pre20060409 72
MD5 7ee737710bef1fd5dd94d975eaf30721 files/digest-palo-1.2_pre20030630 71
MD5 976dc147179cc0e2e54c219e32084c2c files/digest-palo-1.3_pre20040303 71
MD5 552150e078605c297602afb8d8d4c9fe files/digest-palo-1.5_pre20040515 72
@@ -10,6 +11,7 @@ MD5 0df188cd6b8a1188ebd0fc4440753187 files/palo.conf 207
MD5 9eb3e7bb4ebac420842bd3e90dbf8726 metadata.xml 218
MD5 9b8dbce851a68b6b7d7c188e82b5ef9b palo-1.10_pre20051012.ebuild 1153
MD5 efea3eecb37f9fd3b5f9143a277c193d palo-1.13_pre20060123.ebuild 1154
+MD5 c3d904824a6c23ad733c581c9d75cc88 palo-1.14_pre20060409.ebuild 992
MD5 215a7af50439001abaae3f11694675bc palo-1.2_pre20030630.ebuild 933
MD5 bdf378eec83dab3345d0bb28756985c1 palo-1.3_pre20040303.ebuild 934
MD5 88ad675808b43e5bd5c8f0325adba7bd palo-1.5_pre20040515.ebuild 1011
diff --git a/sys-boot/palo/files/digest-palo-1.14_pre20060409 b/sys-boot/palo/files/digest-palo-1.14_pre20060409
new file mode 100644
index 000000000000..789ecd4e3476
--- /dev/null
+++ b/sys-boot/palo/files/digest-palo-1.14_pre20060409
@@ -0,0 +1 @@
+MD5 8cf22a5dbbf012988fe55007f207a2f2 palo-1.14-CVS20060409.tar.gz 95347
diff --git a/sys-boot/palo/palo-1.14_pre20060409.ebuild b/sys-boot/palo/palo-1.14_pre20060409.ebuild
new file mode 100644
index 000000000000..5482195d6768
--- /dev/null
+++ b/sys-boot/palo/palo-1.14_pre20060409.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.14_pre20060409.ebuild,v 1.1 2006/05/30 20:14:37 gmsoft Exp $
+
+inherit eutils
+
+MY_V=${PV/_pre/-CVS}
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://ftp.parisc-linux.org/cvs/palo-${MY_V}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* hppa"
+IUSE=""
+
+DEPEND="virtual/libc"
+PROVIDE="virtual/bootloader"
+
+S=${WORKDIR}/palo
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-remove-HOME-TERM.patch
+}
+
+src_compile() {
+ emake -C palo CFLAGS="${CFLAGS} -I../include -I../lib" || die
+ emake -C ipl CFLAGS="${CFLAGS} -I. -I../lib -I../include -mdisable-fpregs -Wall" || die
+ emake MACHINE=parisc iplboot
+}
+
+src_install() {
+ dosbin palo/palo || die
+ doman palo.8
+ dohtml README.html
+ dodoc README palo.conf
+
+ insinto /etc
+ doins ${FILESDIR}/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+}