summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-03-27 20:40:40 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-03-27 20:40:40 +0000
commitdcfef9b52062c934c3badccf5512cc0277b48428 (patch)
tree94caf9e663388cd01d003a88d2af2314d051ed53 /sys-boot
parentmoved from dev-java/regexp to dev-java/jakarta-regexp dependency. see #71336.... (diff)
downloadgentoo-2-dcfef9b52062c934c3badccf5512cc0277b48428.tar.gz
gentoo-2-dcfef9b52062c934c3badccf5512cc0277b48428.tar.bz2
gentoo-2-dcfef9b52062c934c3badccf5512cc0277b48428.zip
Updated patch from Christophe Saout closes bug #85233.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/ChangeLog6
-rw-r--r--sys-boot/lilo/files/lilo-22.6.1-devmapper_gentoo.patch29
2 files changed, 23 insertions, 12 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index 400f2b576c2c..c28fbc1e6d54 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/lilo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.31 2005/02/27 01:43:46 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.32 2005/03/27 20:40:40 chainsaw Exp $
+
+ 27 Mar 2005; Tony Vroon <chainsaw@gentoo.org>
+ files/lilo-22.6.1-devmapper_gentoo.patch:
+ Updated devmapper patch by Christophe Saout, closes bug #85233.
27 Feb 2005; Tony Vroon <chainsaw@gentoo.org> lilo-22.6.1-r1.ebuild:
Correct pxeserial USE-flag logic.
diff --git a/sys-boot/lilo/files/lilo-22.6.1-devmapper_gentoo.patch b/sys-boot/lilo/files/lilo-22.6.1-devmapper_gentoo.patch
index 2ad3255c0853..44325e71ca51 100644
--- a/sys-boot/lilo/files/lilo-22.6.1-devmapper_gentoo.patch
+++ b/sys-boot/lilo/files/lilo-22.6.1-devmapper_gentoo.patch
@@ -1,6 +1,6 @@
-diff -Nur lilo-22.6.orig/geometry.c lilo-22.6/geometry.c
---- lilo-22.6.orig/geometry.c 2004-08-25 20:21:08.000000000 +0200
-+++ lilo-22.6/geometry.c 2004-09-21 22:42:05.023500680 +0200
+diff -Nur lilo-22.6.1.orig/geometry.c lilo-22.6.1/geometry.c
+--- lilo-22.6.1.orig/geometry.c 2004-11-16 08:11:03.000000000 +0100
++++ lilo-22.6.1/geometry.c 2005-03-15 00:13:42.761215192 +0100
@@ -15,6 +15,9 @@
#include <stdio.h>
#include <fcntl.h>
@@ -151,7 +151,7 @@ diff -Nur lilo-22.6.orig/geometry.c lilo-22.6/geometry.c
}
-@@ -776,6 +848,161 @@
+@@ -777,6 +849,161 @@
{
DT_ENTRY *walk;
int inherited,keep_cyls,is_raid=0;
@@ -313,7 +313,7 @@ diff -Nur lilo-22.6.orig/geometry.c lilo-22.6/geometry.c
if (verbose>=5) printf("geo_get: device %04X, all=%d\n", device, all);
#ifdef LCF_LVM
-@@ -1147,14 +1374,50 @@
+@@ -1154,14 +1381,50 @@
die("EVMS boot volume cannot be on multiple disks.\n");
sector = ebm.rsector + ((offset/SECTOR_SIZE) % geo->spb) + geo->start;
}
@@ -371,10 +371,10 @@ diff -Nur lilo-22.6.orig/geometry.c lilo-22.6/geometry.c
/* DON'T always use CHS addressing on floppies: JRC */
/* if ((geo->device & 0x80) && (linear || lba32)) { */
if ((linear || lba32)) {
-diff -Nur lilo-22.6.orig/Makefile lilo-22.6/Makefile
---- lilo-22.6.orig/Makefile 2004-09-02 20:06:27.000000000 +0200
-+++ lilo-22.6/Makefile 2004-09-21 22:42:05.018501440 +0200
-@@ -53,7 +53,7 @@
+diff -Nur lilo-22.6.1.orig/Makefile lilo-22.6.1/Makefile
+--- lilo-22.6.1.orig/Makefile 2004-11-17 19:41:56.000000000 +0100
++++ lilo-22.6.1/Makefile 2005-03-15 00:14:28.277295696 +0100
+@@ -59,7 +59,7 @@
# XL_SECS=n Support for extra large (non-standard) floppies.
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DONE_SHOT -DPASS160 \
@@ -383,7 +383,7 @@ diff -Nur lilo-22.6.orig/Makefile lilo-22.6/Makefile
# set the compiler optimization level
-@@ -95,6 +95,8 @@
+@@ -101,6 +101,8 @@
LDFLAGS=#-Xlinker -qmagic
LIBS=
@@ -392,7 +392,7 @@ diff -Nur lilo-22.6.orig/Makefile lilo-22.6/Makefile
OBJS=lilo.o raid.o map.o geometry.o boot.o device.o common.o bsect.o cfg.o \
partition.o identify.o probe.o shs2.o edit.o temp.o
-@@ -270,7 +272,11 @@
+@@ -291,10 +293,18 @@
cp -p dparam.S dparam.s
lilo: $(OBJS)
@@ -403,4 +403,11 @@ diff -Nur lilo-22.6.orig/Makefile lilo-22.6/Makefile
+endif
lilo-static: $(OBJS)
++ifneq (,$(findstring DEVMAPPER,$(CONFIG)))
++ $(CC) -o lilo-static -static $(LDFLAGS) $(OBJS) $(LIBS) $(DEVMAPPER)
++else
$(CC) -o lilo-static -static $(LDFLAGS) $(OBJS) $(LIBS)
++endif
+
+ boot-text.b: first.b second.b
+ (dd if=first.b bs=512 conv=sync; dd if=second.b) >boot-text.b