summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-15 23:39:52 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-15 23:39:52 +0000
commitf752634d2cd8740411b12245724739afc4b53c3d (patch)
treea76cef4f1ae5b401295fa9c229a11804ef7a298b /sys-boot
parentamd64 multilib check #85423 (diff)
downloadgentoo-2-f752634d2cd8740411b12245724739afc4b53c3d.tar.gz
gentoo-2-f752634d2cd8740411b12245724739afc4b53c3d.tar.bz2
gentoo-2-f752634d2cd8740411b12245724739afc4b53c3d.zip
Putting ABI stuff inside an 'if use amd64' block.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild10
-rw-r--r--sys-boot/grub/grub-0.94-r2.ebuild10
-rw-r--r--sys-boot/grub/grub-0.95.20040823.ebuild11
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild22
-rw-r--r--sys-boot/grub/grub-0.96.ebuild22
6 files changed, 48 insertions, 34 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 30f02425205c..c9431b0d11f0 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.34 2005/03/11 05:14:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.35 2005/03/15 23:39:52 eradicator Exp $
+
+ 15 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ grub-0.94-r1.ebuild, grub-0.94-r2.ebuild, grub-0.95.20040823.ebuild,
+ grub-0.96.ebuild, grub-0.96-r1.ebuild:
+ Putting ABI stuff inside an 'if use amd64' block.
*grub-0.96-r1 (11 Mar 2005)
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index 7bb34b1c0d26..2e9e41bced44 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.17 2005/03/11 04:29:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.18 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -21,10 +21,12 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+ if use amd64; then
+ has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
- ABI_ALLOW="x86"
- ABI="x86"
+ ABI_ALLOW="x86"
+ ABI="x86"
+ fi
}
src_unpack() {
diff --git a/sys-boot/grub/grub-0.94-r2.ebuild b/sys-boot/grub/grub-0.94-r2.ebuild
index 8e86eb469d11..4749a87f9a7e 100644
--- a/sys-boot/grub/grub-0.94-r2.ebuild
+++ b/sys-boot/grub/grub-0.94-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r2.ebuild,v 1.6 2005/03/11 04:29:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r2.ebuild,v 1.7 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -21,10 +21,12 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+ if use amd64; then
+ has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
- ABI_ALLOW="x86"
- ABI="x86"
+ ABI_ALLOW="x86"
+ ABI="x86"
+ fi
}
src_unpack() {
diff --git a/sys-boot/grub/grub-0.95.20040823.ebuild b/sys-boot/grub/grub-0.95.20040823.ebuild
index 0b5d1cbe9de7..3ce1ba057520 100644
--- a/sys-boot/grub/grub-0.95.20040823.ebuild
+++ b/sys-boot/grub/grub-0.95.20040823.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.14 2005/03/11 04:29:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.15 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -21,10 +21,11 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
-
- ABI_ALLOW="x86"
- ABI="x86"
+ if use amd64; then
+ has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+ ABI_ALLOW="x86"
+ ABI="x86"
+ fi
}
src_unpack() {
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index 534b309b75cc..b3f6b48386c5 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.4 2005/03/12 19:17:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.5 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -22,16 +22,18 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
+ if use amd64; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "If you are on amd64, make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit objects!"
+ fi
+
+ ABI_ALLOW="x86"
+ ABI="x86"
fi
-
- ABI_ALLOW="x86"
- ABI="x86"
}
src_unpack() {
diff --git a/sys-boot/grub/grub-0.96.ebuild b/sys-boot/grub/grub-0.96.ebuild
index 1069c93892c2..75f4cae6faee 100644
--- a/sys-boot/grub/grub-0.96.ebuild
+++ b/sys-boot/grub/grub-0.96.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96.ebuild,v 1.3 2005/03/11 04:29:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96.ebuild,v 1.4 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -22,16 +22,18 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
+ if use amd64; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "If you are on amd64, make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit objects!"
+ fi
+
+ ABI_ALLOW="x86"
+ ABI="x86"
fi
-
- ABI_ALLOW="x86"
- ABI="x86"
}
src_unpack() {