summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-10 00:41:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-10 00:41:33 +0000
commitfb898baefa064fb8b7095c937abe210c13d51ff9 (patch)
treee4e3099641d27021ec85bea30224142fc2f4b2dc /sys-boot
parentnew release (Manifest recommit) (diff)
downloadgentoo-2-fb898baefa064fb8b7095c937abe210c13d51ff9.tar.gz
gentoo-2-fb898baefa064fb8b7095c937abe210c13d51ff9.tar.bz2
gentoo-2-fb898baefa064fb8b7095c937abe210c13d51ff9.zip
Version bump.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/files/digest-syslinux-3.051
-rw-r--r--sys-boot/syslinux/syslinux-3.05.ebuild33
3 files changed, 40 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 81717492cc67..84e7dee53ba6 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.12 2005/01/10 00:32:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.13 2005/01/10 00:41:33 vapier Exp $
+
+*syslinux-3.05 (09 Jan 2005)
+
+ 09 Jan 2005; Mike Frysinger <vapier@gentoo.org> +syslinux-3.05.ebuild:
+ Version bump.
*syslinux-2.13 (09 Jan 2005)
diff --git a/sys-boot/syslinux/files/digest-syslinux-3.05 b/sys-boot/syslinux/files/digest-syslinux-3.05
new file mode 100644
index 000000000000..eec143bad5b7
--- /dev/null
+++ b/sys-boot/syslinux/files/digest-syslinux-3.05
@@ -0,0 +1 @@
+MD5 78cb7cdbc5307c8acde324288bd3a5dc syslinux-3.05.tar.bz2 518449
diff --git a/sys-boot/syslinux/syslinux-3.05.ebuild b/sys-boot/syslinux/syslinux-3.05.ebuild
new file mode 100644
index 000000000000..b0f5118fbbd1
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.05.ebuild,v 1.1 2005/01/10 00:41:33 vapier Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}