summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2007-03-09 11:01:30 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2007-03-09 11:01:30 +0000
commit03b43e69214dc07dfa6fe611a32628ca23a60d53 (patch)
tree28bd4c8dd5d39e34203882f64a517c8fdda41b95 /sys-cluster/cman/cman-1.04.00.ebuild
parentstable x86; bug #169987 (diff)
downloadgentoo-2-03b43e69214dc07dfa6fe611a32628ca23a60d53.tar.gz
gentoo-2-03b43e69214dc07dfa6fe611a32628ca23a60d53.tar.bz2
gentoo-2-03b43e69214dc07dfa6fe611a32628ca23a60d53.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-cluster/cman/cman-1.04.00.ebuild')
-rw-r--r--sys-cluster/cman/cman-1.04.00.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-cluster/cman/cman-1.04.00.ebuild b/sys-cluster/cman/cman-1.04.00.ebuild
new file mode 100644
index 000000000000..9e0ec5a7827b
--- /dev/null
+++ b/sys-cluster/cman/cman-1.04.00.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/cman-1.04.00.ebuild,v 1.1 2007/03/09 11:01:30 xmerlin Exp $
+
+inherit eutils
+
+CLUSTER_RELEASE="1.04.00"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+DESCRIPTION="general-purpose symmetric cluster manager"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="=sys-cluster/ccs-${CLUSTER_RELEASE}*
+ =sys-cluster/cman-headers-${CLUSTER_RELEASE}*"
+
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/cman-1.03.00-compile-hack.patch || die
+}
+
+
+src_compile() {
+ ./configure || die "configure problem"
+ emake -j1 || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install problem"
+
+ newinitd ${FILESDIR}/${PN}.rc ${PN} || die
+ newconfd ${FILESDIR}/${PN}.conf ${PN} || die
+
+ keepdir /etc/cluster || die
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Please add a cluster.conf in /etc/cluster ."
+ einfo ""
+}