summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-10-17 12:39:46 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-10-17 12:39:46 +0000
commit98532224620c997f938568acbb183c74d7ef09b9 (patch)
treeedadfa3063c078176d78f66489bc178abbf7e72b /sys-cluster/corosync
parentversion bump, fix #483712 (diff)
downloadgentoo-2-98532224620c997f938568acbb183c74d7ef09b9.tar.gz
gentoo-2-98532224620c997f938568acbb183c74d7ef09b9.tar.bz2
gentoo-2-98532224620c997f938568acbb183c74d7ef09b9.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/corosync')
-rw-r--r--sys-cluster/corosync/ChangeLog7
-rw-r--r--sys-cluster/corosync/corosync-2.3.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index 14a08d394d76..6d6b6be9c000 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/corosync
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.29 2013/08/29 10:30:17 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.30 2013/10/17 12:39:46 ultrabug Exp $
+
+*corosync-2.3.2 (17 Oct 2013)
+
+ 17 Oct 2013; Ultrabug <ultrabug@gentoo.org> +corosync-2.3.2.ebuild:
+ version bump
*corosync-2.3.1 (29 Aug 2013)
diff --git a/sys-cluster/corosync/corosync-2.3.2.ebuild b/sys-cluster/corosync/corosync-2.3.2.ebuild
new file mode 100644
index 000000000000..4a7b958be66e
--- /dev/null
+++ b/sys-cluster/corosync/corosync-2.3.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-2.3.2.ebuild,v 1.1 2013/10/17 12:39:46 ultrabug Exp $
+
+EAPI=4
+
+inherit autotools base
+
+MY_TREE="2c7906d"
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="https://github.com/corosync/corosync/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc infiniband static-libs"
+
+# TODO: support those new configure flags
+# --enable-watchdog : Watchdog support
+# --enable-augeas : Install the augeas lens for corosync.conf
+# --enable-snmp : SNMP protocol support
+# --enable-xmlconf : XML configuration support
+# --enable-systemd : Install systemd service files
+RDEPEND="!sys-cluster/heartbeat
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )
+ dev-libs/nss
+ >=sys-cluster/libqb-0.14.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.0-docs.patch" )
+
+DOCS=( README.recovery SECURITY TODO AUTHORS )
+
+S="${WORKDIR}/${PN}-${PN}-${MY_TREE}"
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable infiniband rdma)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ rm "${D}"/etc/init.d/corosync-notifyd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+}