summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-10-29 13:56:21 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-10-29 13:56:21 +0000
commitd0a3df365abb0eca007698ea83c08b50d865b61a (patch)
tree82a2eacfbaab71182780842d3462412663d383e7 /sys-cluster/corosync
parentUpdate the virtual to depend on target-aware argparse. (diff)
downloadgentoo-2-d0a3df365abb0eca007698ea83c08b50d865b61a.tar.gz
gentoo-2-d0a3df365abb0eca007698ea83c08b50d865b61a.tar.bz2
gentoo-2-d0a3df365abb0eca007698ea83c08b50d865b61a.zip
corosync-1 series version bump
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/corosync')
-rw-r--r--sys-cluster/corosync/ChangeLog7
-rw-r--r--sys-cluster/corosync/corosync-1.4.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index 19535cce35f7..be1e37331467 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/corosync
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.24 2012/10/29 13:41:52 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.25 2012/10/29 13:56:21 ultrabug Exp $
+
+*corosync-1.4.4 (29 Oct 2012)
+
+ 29 Oct 2012; Ultrabug <ultrabug@gentoo.org> +corosync-1.4.4.ebuild:
+ Version bump of corosync-1 series
*corosync-2.1.0 (29 Oct 2012)
diff --git a/sys-cluster/corosync/corosync-1.4.4.ebuild b/sys-cluster/corosync/corosync-1.4.4.ebuild
new file mode 100644
index 000000000000..a30a45328d4c
--- /dev/null
+++ b/sys-cluster/corosync/corosync-1.4.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.4.4.ebuild,v 1.1 2012/10/29 13:56:21 ultrabug Exp $
+
+EAPI=4
+
+inherit base autotools
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="https://github.com/downloads/corosync/corosync/${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
+IUSE="doc infiniband ssl static-libs"
+
+RDEPEND="!sys-cluster/heartbeat
+ ssl? ( dev-libs/nss )
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docs.patch"
+)
+
+DOCS=( README.recovery README.devmap SECURITY TODO AUTHORS )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable ssl nss) \
+ $(use_enable infiniband rdma)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ rm "${D}"/etc/init.d/corosync-notifyd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+}