summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-20 21:49:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-20 21:49:38 +0000
commitc10a799d4facdf50d4fd92f89da89e5544828305 (patch)
treee30101a6af0b3d26db29f7d38598ae26c516585c /sys-cluster/gearmand
parentFix metadata: maintainer-wanted herd does not exist (diff)
downloadgentoo-2-c10a799d4facdf50d4fd92f89da89e5544828305.tar.gz
gentoo-2-c10a799d4facdf50d4fd92f89da89e5544828305.tar.bz2
gentoo-2-c10a799d4facdf50d4fd92f89da89e5544828305.zip
Revision bump, add support for dev-db/libdrizzle, sqlite and write the code to support postgresql (albeit non-working yet).
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/gearmand')
-rw-r--r--sys-cluster/gearmand/ChangeLog9
-rw-r--r--sys-cluster/gearmand/gearmand-0.11-r2.ebuild (renamed from sys-cluster/gearmand/gearmand-0.11-r1.ebuild)43
-rw-r--r--sys-cluster/gearmand/metadata.xml5
3 files changed, 41 insertions, 16 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index 1f770ada606c..9a460277d1d2 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/gearmand
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.1 2009/12/20 19:19:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.2 2009/12/20 21:49:38 flameeyes Exp $
+
+*gearmand-0.11-r2 (20 Dec 2009)
+
+ 20 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -gearmand-0.11-r1.ebuild, +gearmand-0.11-r2.ebuild, metadata.xml:
+ Revision bump, add support for dev-db/libdrizzle, sqlite and write the
+ code to support postgresql (albeit non-working yet).
*gearmand-0.11-r1 (20 Dec 2009)
diff --git a/sys-cluster/gearmand/gearmand-0.11-r1.ebuild b/sys-cluster/gearmand/gearmand-0.11-r2.ebuild
index d87329b9e686..e248b58f7f08 100644
--- a/sys-cluster/gearmand/gearmand-0.11-r1.ebuild
+++ b/sys-cluster/gearmand/gearmand-0.11-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.11-r1.ebuild,v 1.1 2009/12/20 19:19:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.11-r2.ebuild,v 1.1 2009/12/20 21:49:38 flameeyes Exp $
EAPI=2
-inherit flag-o-matic
+inherit flag-o-matic libtool
DESCRIPTION="Generic framework to farm out work to other machines"
HOMEPAGE="http://www.gearman.org/"
@@ -13,21 +13,27 @@ SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="debug tcmalloc +memcache"
+IUSE="debug tcmalloc +memcache drizzle sqlite" # postgres
+# postgresql support is broken right now so keep it disabled
RDEPEND="dev-libs/libevent
|| ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
tcmalloc? ( dev-util/google-perftools )
- memcache? ( dev-libs/libmemcached )"
+ memcache? ( dev-libs/libmemcached )
+ drizzle? ( dev-db/libdrizzle )
+ sqlite? ( dev-db/sqlite:3 )
+ postgres? ( dev-db/postgresql-base )"
DEPEND="${RDEPEND}"
pkg_setup() {
enewuser gearmand -1 -1 /dev/null nogroup
}
-src_configure() {
- local myconf=
+src_prepare() {
+ elibtoolize
+}
+src_configure() {
# Don't ever use --enable-assert since configure.ac is broken, and
# only does --disable-assert correctly.
if use debug; then
@@ -42,19 +48,26 @@ src_configure() {
# myconf="${myconf} --disable-assert"
fi
- # TODO once there's a drizzle/librizzle ebuild, add drizzle to iuse
- # TODO new compile options for queue storage: libsqlite,libpq,libdrizzle
- # TODO mtmalloc, umem, dtrace - all of this solaris stuff only?
- # TODO libmemcached pulls memcached. Is this correct?
econf \
--disable-dependency-tracking \
+ --disable-mtmalloc \
$(use_enable tcmalloc) \
$(use_enable memcache libmemcached) \
- --disable-mtmalloc \
- --disable-libsqlite3 \
- --disable-libdrizzle \
- --disable-libpq \
- ${myconf}
+ $(use_enable drizzle libdrizzle) \
+ $(use_enable sqlite libsqlite3) \
+ $(use_enable postgres libpq)
+}
+
+src_test() {
+ # Since libtool is stupid and doesn't discard /usr/lib64 from the
+ # load path, we'd end up testing against the installed copy of
+ # gearmand (bad).
+ #
+ # We thus cheat and "fix" the scripts by hand.
+ sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
+ || die "test fixing failed"
+
+ emake check || die "tests failed"
}
src_install() {
diff --git a/sys-cluster/gearmand/metadata.xml b/sys-cluster/gearmand/metadata.xml
index 898d240b8d4c..1a3565061d04 100644
--- a/sys-cluster/gearmand/metadata.xml
+++ b/sys-cluster/gearmand/metadata.xml
@@ -20,5 +20,10 @@
Support memcache daemon (via <pkg>dev-libs/libmemcached</pkg>)
for the queue storage.
</flag>
+
+ <flag name="drizzle">
+ Support <pkg>dev-db/libdrizzle</pkg> for the queue storage. This
+ also adds support for MySQL storage.
+ </flag>
</use>
</pkgmetadata>