summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-03-08 17:54:24 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-03-08 17:54:24 +0000
commit46a092fc63e77835fe26b618a89a80d34486e5c4 (patch)
tree3215ae18fddb497f9c0916d0767a8d8455a79a6f /sys-cluster/libqb
parentbump (diff)
downloadgentoo-2-46a092fc63e77835fe26b618a89a80d34486e5c4.tar.gz
gentoo-2-46a092fc63e77835fe26b618a89a80d34486e5c4.tar.bz2
gentoo-2-46a092fc63e77835fe26b618a89a80d34486e5c4.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/libqb')
-rw-r--r--sys-cluster/libqb/ChangeLog10
-rw-r--r--sys-cluster/libqb/libqb-0.14.4.ebuild52
2 files changed, 59 insertions, 3 deletions
diff --git a/sys-cluster/libqb/ChangeLog b/sys-cluster/libqb/ChangeLog
index 7e01cee68f01..c6a56d24bf1f 100644
--- a/sys-cluster/libqb/ChangeLog
+++ b/sys-cluster/libqb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/libqb
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/ChangeLog,v 1.3 2012/11/14 17:23:50 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/ChangeLog,v 1.4 2013/03/08 17:54:24 ultrabug Exp $
+
+*libqb-0.14.4 (08 Mar 2013)
+
+ 08 Mar 2013; Ultrabug <ultrabug@gentoo.org> +libqb-0.14.4.ebuild:
+ Version bump
14 Nov 2012; Jeroen Roovers <jer@gentoo.org> libqb-0.14.3.ebuild:
Marked ~hppa (bug #442408).
@@ -15,4 +20,3 @@
16 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +libqb-0.13.0.ebuild,
+metadata.xml:
Initial import, ebuild written by me
-
diff --git a/sys-cluster/libqb/libqb-0.14.4.ebuild b/sys-cluster/libqb/libqb-0.14.4.ebuild
new file mode 100644
index 000000000000..4680dc74358b
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.14.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/libqb-0.14.4.ebuild,v 1.1 2013/03/08 17:54:24 ultrabug Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}