summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-05 01:25:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-05 01:25:54 +0000
commit0087d6e6c639d90cb257c69711effb376add78c2 (patch)
treef3cbb44b3474310a0fdda75bc8b8d833fb4d977a /sys-cluster/maui/maui-3.2.6_p13.ebuild
parentAdd maui license for sys-cluster/maui - this is a modified GPL, with commerci... (diff)
downloadgentoo-2-0087d6e6c639d90cb257c69711effb376add78c2.tar.gz
gentoo-2-0087d6e6c639d90cb257c69711effb376add78c2.tar.bz2
gentoo-2-0087d6e6c639d90cb257c69711effb376add78c2.zip
Initial commit of sys-cluster/maui. Ebuild by Pat Lougheed <patl@sfu.ca> and Robin Hugh Johnson <robbat2@gentoo.org>.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster/maui/maui-3.2.6_p13.ebuild')
-rw-r--r--sys-cluster/maui/maui-3.2.6_p13.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-cluster/maui/maui-3.2.6_p13.ebuild b/sys-cluster/maui/maui-3.2.6_p13.ebuild
new file mode 100644
index 000000000000..1dbb759cc72b
--- /dev/null
+++ b/sys-cluster/maui/maui-3.2.6_p13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.2.6_p13.ebuild,v 1.1 2005/07/05 01:25:54 robbat2 Exp $
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/products/maui/"
+SRC_URI="http://www.clusterresources.com/downloads/maui/${P/_/}.tar.gz"
+IUSE=""
+DEPEND=">=sys-cluster/torque-1.2.0_p1-r1"
+RDEPEND="${DEPEND}
+ virtual/libc"
+SLOT="0"
+LICENSE="maui"
+KEYWORDS="~x86"
+RESTRICT="fetch nomirror"
+
+S="${WORKDIR}/${P/_/}"
+
+src_compile() {
+ econf --with-spooldir=/usr/spool/maui --with-pbs || die "econf failed!"
+
+ # Torque on Gentoo installs libnet.a, which clobbers libnet.a from libnet.
+ # (Stupid developers.) Unfortunately, libnet also installs libnet.so, which
+ # Torque doesn't clobber, so when running make we end up linking against
+ # .so rather than .a. Big problem. Fix it.
+
+ sed -i -e "s~-lnet~/usr/lib/torque/libnet.a~" Makefile
+ sed -i -e "s~-lpbs~/usr/lib/torque/libpbs.a~" Makefile
+ sed -i -e "s~BUILDROOT=~BUILDROOT=${D}~" Makefile
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make install INST_DIR=${D}/usr
+
+ cd docs
+ dodoc README mauidocs.html
+}