summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-09-13 22:20:52 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-09-13 22:20:52 +0000
commit14abe286c2b3a65b1396e205caded2ba6716c90f (patch)
tree57dd841b96e0248b6edbc30df2d61f198e90fc86 /sys-cluster/mpe2
parentStable on alpha, bug #315775 (diff)
downloadgentoo-2-14abe286c2b3a65b1396e205caded2ba6716c90f.tar.gz
gentoo-2-14abe286c2b3a65b1396e205caded2ba6716c90f.tar.bz2
gentoo-2-14abe286c2b3a65b1396e205caded2ba6716c90f.zip
Disable parallel make per upstream, http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/mpe2')
-rw-r--r--sys-cluster/mpe2/ChangeLog7
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild10
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild13
3 files changed, 22 insertions, 8 deletions
diff --git a/sys-cluster/mpe2/ChangeLog b/sys-cluster/mpe2/ChangeLog
index 00c2fd6db16f..1477c50ed580 100644
--- a/sys-cluster/mpe2/ChangeLog
+++ b/sys-cluster/mpe2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/mpe2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v 1.4 2010/09/13 18:38:12 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v 1.5 2010/09/13 22:20:52 jsbronder Exp $
+
+ 13 Sep 2010; Justin Bronder <jsbronder@gentoo.org> mpe2-1.0.6_p1.ebuild,
+ mpe2-1.0.6_p1-r1.ebuild:
+ Disable parallel make per upstream,
+ http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
*mpe2-1.0.6_p1-r1 (13 Sep 2010)
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
index 9bfbe60ca577..33e6c36a73b3 100644
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
+++ b/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild,v 1.1 2010/09/13 18:38:12 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild,v 1.2 2010/09/13 22:20:52 jsbronder Exp $
EAPI=2
inherit fortran eutils java-utils-2
@@ -122,7 +122,9 @@ src_test() {
return 0
fi
- emake \
+ # No parallel make:
+ # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
+ emake -j1 \
CC="${S}"/bin/mpecc \
FC="${S}"/bin/mpefc \
MPERUN="${ROOT}/usr/bin/mpiexec -n 4" \
@@ -137,6 +139,8 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ # No parallel make:
+ # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
+ emake -j1 DESTDIR="${D}" install || die
rm -f "${D}"/usr/sbin/mpeuninstall || die
}
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
index 9759b18f5064..55d0a5c7e4fa 100644
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
+++ b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild,v 1.3 2009/12/28 23:48:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild,v 1.4 2010/09/13 22:20:52 jsbronder Exp $
EAPI=2
inherit fortran eutils java-utils-2
@@ -120,7 +120,10 @@ src_test() {
return 0
fi
- emake \
+
+ # No parallel make:
+ # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
+ emake -j1 \
CC="${S}"/bin/mpecc \
FC="${S}"/bin/mpefc \
MPERUN="${ROOT}/usr/bin/mpiexec -n 4" \
@@ -135,6 +138,8 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ # No parallel make:
+ # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
+ emake -j1 DESTDIR="${D}" install || die
rm -f "${D}"/usr/sbin/mpeuninstall || die
}