summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-11-07 01:46:50 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-11-07 01:46:50 +0000
commit0d2560a2397e9037762809c34b9132e8b175a590 (patch)
treeee0043101d833263322c6970d0b28cdf9540a031 /sys-cluster/mpich
parent(#103218) Overrule mpich's broken build system to get datadir set to /usr/sha... (diff)
downloadgentoo-2-0d2560a2397e9037762809c34b9132e8b175a590.tar.gz
gentoo-2-0d2560a2397e9037762809c34b9132e8b175a590.tar.bz2
gentoo-2-0d2560a2397e9037762809c34b9132e8b175a590.zip
Bump to the latest, released only 2 days ago. This probably makes our mpich current for the first time in a year.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/ChangeLog9
-rw-r--r--sys-cluster/mpich/files/1.2.7_p1-fix-romio-sandbox-breakage.patch12
-rw-r--r--sys-cluster/mpich/files/digest-mpich-1.2.7_p11
-rw-r--r--sys-cluster/mpich/mpich-1.2.7_p1.ebuild153
4 files changed, 174 insertions, 1 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index d0a107c4a08b..7cef38ac4ca9 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/mpich
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.22 2005/11/07 01:31:39 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.23 2005/11/07 01:46:50 spyderous Exp $
+
+*mpich-1.2.7_p1 (07 Nov 2005)
+
+ 07 Nov 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/1.2.7_p1-fix-romio-sandbox-breakage.patch, +mpich-1.2.7_p1.ebuild:
+ Bump to the latest, released only 2 days ago. This probably makes our mpich
+ current for the first time in a year.
*mpich-1.2.6-r4 (07 Nov 2005)
diff --git a/sys-cluster/mpich/files/1.2.7_p1-fix-romio-sandbox-breakage.patch b/sys-cluster/mpich/files/1.2.7_p1-fix-romio-sandbox-breakage.patch
new file mode 100644
index 000000000000..09ecef36919d
--- /dev/null
+++ b/sys-cluster/mpich/files/1.2.7_p1-fix-romio-sandbox-breakage.patch
@@ -0,0 +1,12 @@
+diff -urN mpich-1.2.7p1.orig/romio/configure.in mpich-1.2.7p1/romio/configure.in
+--- mpich-1.2.7p1.orig/romio/configure.in 2004-08-02 06:37:31.000000000 -0700
++++ mpich-1.2.7p1/romio/configure.in 2005-02-20 23:35:18.163959288 -0800
+@@ -1621,7 +1621,7 @@
+ #
+ # Make sure we remove any configuration file incase there is out-of-date data.
+ # We remove the version in include in case this is a vpath build
+-rm -f adio/include/romioconf.h ${use_top_srcdir}/src/mpi/romio/adio/include/romioconf.h ${use_top_srcdir}/adio/include/romioconf.h
++rm -f adio/include/romioconf.h
+ #
+ # Create makefiles for all of the adio devices. Only the ones that
+ # are active will be called by the top level ROMIO make
diff --git a/sys-cluster/mpich/files/digest-mpich-1.2.7_p1 b/sys-cluster/mpich/files/digest-mpich-1.2.7_p1
new file mode 100644
index 000000000000..4d6a2b5447ad
--- /dev/null
+++ b/sys-cluster/mpich/files/digest-mpich-1.2.7_p1
@@ -0,0 +1 @@
+MD5 7a4ac672b4b358ce519a93b70f771bee mpich-1.2.7p1.tar.gz 15978525
diff --git a/sys-cluster/mpich/mpich-1.2.7_p1.ebuild b/sys-cluster/mpich/mpich-1.2.7_p1.ebuild
new file mode 100644
index 000000000000..4087b6561ac7
--- /dev/null
+++ b/sys-cluster/mpich/mpich-1.2.7_p1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.7_p1.ebuild,v 1.1 2005/11/07 01:46:50 spyderous Exp $
+
+inherit eutils
+
+# Set the MPICH_CONFIGURE_OPTS environment variable to change the signal
+# mpich listens on or any other custom options (#38207).
+# The default USR1 conflicts with pthreads. Options include SIGUSR2 and SIGBUS.
+# For example: MPICH_CONFIGURE_OPTS="--with-device=ch_p4:-listener_sig=SIGBUS"
+
+MY_P="${PN}-${PV/_}"
+
+DESCRIPTION="MPICH - A portable MPI implementation"
+HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc64"
+IUSE="doc crypt"
+
+PROVIDE="virtual/mpi"
+DEPEND="virtual/libc
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !virtual/mpi
+ || ( x11-libs/libX11
+ virtual/x11 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if [ -n "${MPICH_CONFIGURE_OPTS}" ]; then
+ einfo "Custom configure options are ${MPICH_CONFIGURE_OPTS}."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep -FrlZ '$(P) ' . | xargs -0 sed -i -e 's/\$(P)//'
+
+ # Fix broken romio
+ epatch ${FILESDIR}/${PV}-fix-romio-sandbox-breakage.patch
+ cd ${S}/romio
+ rm configure
+ autoreconf --install --verbose
+}
+
+src_compile() {
+ local RSHCOMMAND
+
+ if use crypt; then
+ RSHCOMMAND="ssh -x"
+ else
+ RSHCOMMAND="rsh"
+ fi
+
+ export RSHCOMMAND
+
+ local myconf="${myconf} ${MPICH_CONFIGURE_OPTS}"
+
+ ./configure \
+ ${myconf} \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --datadir=/usr/share/mpich || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/sbin
+
+ # mpich install process is really weird, need to do some hand work perhaps
+
+ # to skip installation of man pages, uncomment following line
+ # export MPIINSTALL_OPTS=-noman
+
+ ./bin/mpiinstall -echo -prefix=${D}/usr || die
+
+ if use doc; then
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/doc/* ${D}/usr/share/doc/${PF}
+ fi
+ rm -rf ${D}/usr/doc/
+
+ dodir /etc/mpich
+ mv ${D}/usr/etc/* ${D}/etc/mpich/
+ rmdir ${D}/usr/etc/
+
+ dodir /usr/share/${PN}
+ mv ${D}/usr/examples ${D}/usr/share/${PN}/examples1
+ mv ${D}/usr/share/examples ${D}/usr/share/${PN}/examples2
+
+ # rm -rf ${D}/usr/local
+ rm -f ${D}/usr/man/mandesc
+
+ mv ${D}/usr/share/{machines*,jumpshot-3,Makefile.sample,upshot} ${D}/usr/share/${PN}
+
+ dodoc COPYRIGHT README
+ use doc && \
+ mv ${D}/usr/www ${D}/usr/share/doc/${PF}/html || \
+ rm -rf ${D}/usr/www
+
+ # Dont let users deinstall without portage
+ rm ${D}/usr/sbin/mpiuninstall
+
+ # We dont have a real DESTDIR, so we have to fix all the files
+ dosed /usr/bin/mpirun /usr/bin/mpiman /usr/sbin/tstmachines
+ dosed /usr/sbin/chkserv /usr/sbin/chp4_servs
+ dosed /usr/bin/clog2TOslog2 /usr/bin/clog2print
+ dosed /usr/bin/clogTOslog2 /usr/bin/clogprint
+ dosed /usr/bin/jumpshot /usr/bin/logconvertor
+ dosed /usr/bin/mpicc /usr/bin/mpiCC /usr/bin/logviewer
+ dosed /usr/bin/mpicxx
+ dosed /usr/bin/mpireconfig /usr/bin/mpireconfig.dat
+ dosed /usr/bin/mpereconfig /usr/bin/mpereconfig.dat
+ dosed /usr/bin/rlogTOslog2 /usr/bin/rlogprint
+ dosed /usr/bin/slog2navigator /usr/bin/slog2print
+
+ dosed /usr/share/mpich/examples1/Makefile
+ dosed /usr/share/mpich/examples2/Makefile
+ dosed /usr/share/mpich/jumpshot-3/bin/jumpshot
+ dosed /usr/share/mpich/jumpshot-3/bin/slog_print
+ dosed /usr/share/mpich/Makefile.sample
+ dosed /usr/share/mpich/upshot/bin/upshot
+
+ # Fix datadir; mpich's build system screws it up even though we pass it
+ grep -rl 'datadir=.*' ${D} \
+ | xargs sed -i -e "s:datadir=.*:datadir=/usr/share/mpich:g"
+
+ # those are dangling symlinks
+ rm -f \
+ ${D}/usr/share/mpich/examples1/mpirun \
+ ${D}/usr/share/mpich/examples2/mpirun
+
+ mv ${D}/usr/man ${D}/usr/share/man
+ prepallman
+
+ #FIXME: Here, we should either clean the empty directories
+ # or use keepdir to make sure they stick around.
+}
+
+pkg_postinst() {
+ einfo "The data directory has moved from /usr/share"
+ einfo "to /usr/share/mpich."
+ einfo "Remeber to move your machines.* files."
+}