summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2013-07-11 01:03:55 +0000
committerJustin Bronder <jsbronder@gentoo.org>2013-07-11 01:03:55 +0000
commitbb4922e8c9f2c2bba2a2c602f8cca37b8f635091 (patch)
tree6f3d1f696c7aadad8be58f678dbf703d1ea02da6 /sys-cluster/openmpi
parentversion bump (diff)
downloadgentoo-2-bb4922e8c9f2c2bba2a2c602f8cca37b8f635091.tar.gz
gentoo-2-bb4922e8c9f2c2bba2a2c602f8cca37b8f635091.tar.bz2
gentoo-2-bb4922e8c9f2c2bba2a2c602f8cca37b8f635091.zip
bump and cleanup
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog8
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.4.ebuild104
-rw-r--r--sys-cluster/openmpi/openmpi-1.6.5.ebuild (renamed from sys-cluster/openmpi/openmpi-1.6.4-r1.ebuild)2
3 files changed, 8 insertions, 106 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 37039cf88828..21c65be55d0d 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.121 2013/07/09 22:28:16 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.122 2013/07/11 01:03:55 jsbronder Exp $
+
+*openmpi-1.6.5 (11 Jul 2013)
+
+ 11 Jul 2013; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.4.4.ebuild,
+ -openmpi-1.6.4-r1.ebuild, +openmpi-1.6.5.ebuild:
+ bump and cleanup
09 Jul 2013; Justin Bronder <jsbronder@gentoo.org> openmpi-1.4.3.ebuild,
openmpi-1.4.4.ebuild, openmpi-1.4.5.ebuild, openmpi-1.6.3.ebuild,
diff --git a/sys-cluster/openmpi/openmpi-1.4.4.ebuild b/sys-cluster/openmpi/openmpi-1.4.4.ebuild
deleted file mode 100644
index 06fd47fdaedf..000000000000
--- a/sys-cluster/openmpi/openmpi-1.4.4.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.4.ebuild,v 1.5 2013/07/09 22:28:16 jsbronder Exp $
-
-EAPI=3
-
-FORTRAN_NEEDED=fortran
-
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
-
-MY_P=${P/-mpi}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.4/downloads/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
-RDEPEND="
- pbs? ( sys-cluster/torque )
- vt? (
- !dev-libs/libotf
- !app-text/lcdf-typetools
- )
- elibc_FreeBSD? ( dev-libs/libexecinfo )
- !sys-cluster/mpich
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- fortran-2_pkg_setup
- if use mpi-threads; then
- echo
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- echo
- fi
-
- echo
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- echo
-}
-
-src_prepare() {
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}/etc/${PN}"
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm)
-
- if use mpi-threads; then
- myconf+=(--enable-mpi-threads
- --enable-progress-threads)
- fi
-
- if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
- else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
- fi
-
- ! use vt && myconf+=(--enable-contrib-no-build=vt)
-
- econf "${myconf[@]}" \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6)
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION || die
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.6.4-r1.ebuild b/sys-cluster/openmpi/openmpi-1.6.5.ebuild
index d5961b88f3ec..0bc0144fedb7 100644
--- a/sys-cluster/openmpi/openmpi-1.6.4-r1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6.4-r1.ebuild,v 1.3 2013/07/09 22:28:16 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6.5.ebuild,v 1.1 2013/07/11 01:03:55 jsbronder Exp $
EAPI=5