summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-24 15:09:06 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-24 15:09:06 +0000
commitc9885dc0ae40c7bfdb4adcf6d93b2bc54b782c9c (patch)
tree25ce7b0159fc62cb27cf6b194a532f3023c8800d /sys-cluster/openmpi
parentalpha/arm/ia64/s390/sh/sparc stable wrt #371763 (diff)
downloadgentoo-2-c9885dc0ae40c7bfdb4adcf6d93b2bc54b782c9c.tar.gz
gentoo-2-c9885dc0ae40c7bfdb4adcf6d93b2bc54b782c9c.tar.bz2
gentoo-2-c9885dc0ae40c7bfdb4adcf6d93b2bc54b782c9c.zip
Do not check for fortran unconditionally, #372849
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog6
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.2.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.3.ebuild6
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.3.ebuild6
4 files changed, 14 insertions, 10 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 57ab9ee901f5..80234f85065c 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.84 2011/06/21 14:22:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.85 2011/06/24 15:09:06 jlec Exp $
+
+ 24 Jun 2011; Justin Lecher <jlec@gentoo.org> openmpi-1.4.2.ebuild,
+ openmpi-1.4.3.ebuild, openmpi-1.5.3.ebuild:
+ Do not check for fortran unconditionally, #372849
21 Jun 2011; Justin Lecher <jlec@gentoo.org> openmpi-1.4.2.ebuild,
openmpi-1.4.3.ebuild, openmpi-1.5.3.ebuild:
diff --git a/sys-cluster/openmpi/openmpi-1.4.2.ebuild b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
index 5d3b73b1e3ee..758e28819883 100644
--- a/sys-cluster/openmpi/openmpi-1.4.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.16 2011/06/21 14:22:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.17 2011/06/24 15:09:06 jlec Exp $
EAPI=3
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
@@ -18,7 +18,7 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
RDEPEND="
fortran? ( virtual/fortran )
-pbs? ( sys-cluster/torque )
+ pbs? ( sys-cluster/torque )
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
@@ -31,7 +31,7 @@ pbs? ( sys-cluster/torque )
DEPEND="${RDEPEND}"
pkg_setup() {
- fortran-2_pkg_setup
+ use fortran && fortran-2_pkg_setup
if use mpi-threads; then
echo
ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
diff --git a/sys-cluster/openmpi/openmpi-1.4.3.ebuild b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
index 73f2e44bf050..8177c609c522 100644
--- a/sys-cluster/openmpi/openmpi-1.4.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.9 2011/06/21 14:22:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.10 2011/06/24 15:09:06 jlec Exp $
EAPI=3
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
@@ -18,7 +18,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
RDEPEND="
fortran? ( virtual/fortran )
-pbs? ( sys-cluster/torque )
+ pbs? ( sys-cluster/torque )
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
@@ -31,7 +31,7 @@ pbs? ( sys-cluster/torque )
DEPEND="${RDEPEND}"
pkg_setup() {
- fortran-2_pkg_setup
+ use fortran && fortran-2_pkg_setup
if use mpi-threads; then
echo
ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
diff --git a/sys-cluster/openmpi/openmpi-1.5.3.ebuild b/sys-cluster/openmpi/openmpi-1.5.3.ebuild
index fef646a0bb6d..572dee6b9c72 100644
--- a/sys-cluster/openmpi/openmpi-1.5.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3.ebuild,v 1.5 2011/06/21 14:22:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3.ebuild,v 1.6 2011/06/24 15:09:06 jlec Exp $
EAPI=3
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
RDEPEND="
fortran? ( virtual/fortran )
-pbs? ( sys-cluster/torque )
+ pbs? ( sys-cluster/torque )
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
@@ -31,7 +31,7 @@ pbs? ( sys-cluster/torque )
DEPEND="${RDEPEND}"
pkg_setup() {
- fortran-2_pkg_setup
+ use fortran && fortran-2_pkg_setup
if use mpi-threads; then
echo
ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"