summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-12-03 16:06:11 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-12-03 16:06:11 +0000
commit22627a0c860668016d4afb890360b72a2a59ee71 (patch)
tree864d09b974f28047fe19cd03ff9455ec9623ddbe /sys-cluster/vzctl
parentadjust eudev atoms so that both USE=kmod or USE=modutils can satisfy virtual/... (diff)
downloadgentoo-2-22627a0c860668016d4afb890360b72a2a59ee71.tar.gz
gentoo-2-22627a0c860668016d4afb890360b72a2a59ee71.tar.bz2
gentoo-2-22627a0c860668016d4afb890360b72a2a59ee71.zip
vzctl-4.6.1 version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/metadata.xml1
-rw-r--r--sys-cluster/vzctl/vzctl-4.6.1.ebuild92
3 files changed, 100 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 88ee8e168a0a..b4bf55b0a6ba 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.118 2013/10/19 16:09:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.119 2013/12/03 16:06:11 qnikst Exp $
+
+*vzctl-4.6.1 (03 Dec 2013)
+
+ 03 Dec 2013; Alexander Vershilov <qnikst@gentoo.org> +vzctl-4.6.1.ebuild,
+ metadata.xml:
+ vzctl-4.6.1 version bump
19 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due vserver removal
diff --git a/sys-cluster/vzctl/metadata.xml b/sys-cluster/vzctl/metadata.xml
index 4f8e928d65c0..09ba5bb5c47e 100644
--- a/sys-cluster/vzctl/metadata.xml
+++ b/sys-cluster/vzctl/metadata.xml
@@ -12,6 +12,7 @@
<flag name='cgroup'>Add support to Linux kernel cgroup subsytem</flag>
<flag name='vz-kernel'>Support OpenVZ patched kernel (<pkg>sys-kernel/openvz-sources</pkg>)</flag>
<flag name='vanilla-kernel'>Support unpatched upstream Linux kernel</flag>
+ <flag name='vzmigrate'>Add support for container migration</flag>
</use>
<upstream>
<maintainer status="active">
diff --git a/sys-cluster/vzctl/vzctl-4.6.1.ebuild b/sys-cluster/vzctl/vzctl-4.6.1.ebuild
new file mode 100644
index 000000000000..711b53198988
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-4.6.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.6.1.ebuild,v 1.1 2013/12/03 16:06:11 qnikst Exp $
+
+EAPI="5"
+
+inherit base bash-completion-r1 eutils toolchain-funcs udev
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc64 -amd64-fbsd -x86-fbsd -sparc-fbsd"
+IUSE="+ploop +vz-kernel +vzmigrate"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ vz-kernel? ( >=sys-fs/vzquota-3.1 )
+ ploop? (
+ >=sys-cluster/ploop-1.9
+ sys-block/parted
+ sys-fs/quota
+ )
+ >=dev-libs/libcgroup-0.38
+ vzmigrate? (
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+ app-arch/tar[xattr,acl]
+ )
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+src_prepare() {
+
+ # Set default OSTEMPLATE on gentoo
+ sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
+ # Set proper udev directory
+ sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
+}
+
+src_configure() {
+
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate \
+ --with-vz \
+ $(use_with ploop) \
+ --with-cgroup
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" udevdir="$(udev_get_udevdir)"/rules.d install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+
+ einfo "You have chose to "vanilla" kernel."
+ einfo "If you have checkpoint suspend/restore feature in vanilla kernel"
+ einfo "please install "sys-process/criu" "
+ einfo "This is experimental and not stable ( in gentoo ) now"
+
+ einfo "if you have work with .xz compressed template, please install app-arch/xz-utils"
+ einfo "if you have check signature donwloaded template - install gpg "
+
+}