summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-08-12 15:26:38 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-08-12 15:26:38 +0000
commit4c44b345d84e3f2cc3bbf5ddb76526794e3a69c9 (patch)
treef37747d52a86f6284c1aa9bef7a81524f8ba0edd /sys-cluster
parentStable for x86, wrt bug #509858 (diff)
downloadgentoo-2-4c44b345d84e3f2cc3bbf5ddb76526794e3a69c9.tar.gz
gentoo-2-4c44b345d84e3f2cc3bbf5ddb76526794e3a69c9.tar.bz2
gentoo-2-4c44b345d84e3f2cc3bbf5ddb76526794e3a69c9.zip
version bump
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/libqb/ChangeLog9
-rw-r--r--sys-cluster/libqb/libqb-0.17.0.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/sys-cluster/libqb/ChangeLog b/sys-cluster/libqb/ChangeLog
index 568cf4129618..4d25e47b06dd 100644
--- a/sys-cluster/libqb/ChangeLog
+++ b/sys-cluster/libqb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/libqb
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/ChangeLog,v 1.5 2013/10/20 13:40:59 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/ChangeLog,v 1.6 2014/08/12 15:26:38 ultrabug Exp $
+
+*libqb-0.17.0 (12 Aug 2014)
+
+ 12 Aug 2014; Ultrabug <ultrabug@gentoo.org> +libqb-0.17.0.ebuild:
+ version bump
20 Oct 2013; Jeroen Roovers <jer@gentoo.org> libqb-0.14.4.ebuild:
Stable for HPPA (bug #457572).
diff --git a/sys-cluster/libqb/libqb-0.17.0.ebuild b/sys-cluster/libqb/libqb-0.17.0.ebuild
new file mode 100644
index 000000000000..68fef46cd5f8
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.17.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/libqb-0.17.0.ebuild,v 1.1 2014/08/12 15:26:38 ultrabug Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}