summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-05-01 21:38:46 +0000
committerMichael Imhof <tantive@gentoo.org>2003-05-01 21:38:46 +0000
commit57505b055bd5f1a674d96873aae5da525b84cf59 (patch)
treeb9b826e5737d95e1693be6fb364cfcb7c9e88846 /sys-cluster
parentstable on alpha (diff)
downloadgentoo-2-57505b055bd5f1a674d96873aae5da525b84cf59.tar.gz
gentoo-2-57505b055bd5f1a674d96873aae5da525b84cf59.tar.bz2
gentoo-2-57505b055bd5f1a674d96873aae5da525b84cf59.zip
Added sed magic to make sue openmosix.config gets installed into /etc and not /etc/openmosix as the init script looks for /etc/openmosix.config
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmosix-user/ChangeLog8
-rw-r--r--sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r11
-rw-r--r--sys-cluster/openmosix-user/openmosix-user-0.3-r1.ebuild96
3 files changed, 104 insertions, 1 deletions
diff --git a/sys-cluster/openmosix-user/ChangeLog b/sys-cluster/openmosix-user/ChangeLog
index ab21d30a95a4..1b7d7a6d12dc 100644
--- a/sys-cluster/openmosix-user/ChangeLog
+++ b/sys-cluster/openmosix-user/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/openmosix-user
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/ChangeLog,v 1.8 2003/04/12 17:34:35 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/ChangeLog,v 1.9 2003/05/01 21:38:46 tantive Exp $
+
+* openmosix-user-0.3.-r1 (01 May 2003)
+
+ 01 May 2003; Michael Imhof <tantive@gentoo.org>
+ Add sed magic to make sure openmosix.config get's installed into /etc and not into /etc/openmosix
+ as the init script looks into /etc.
* openmosix-user-0.3 (12 Apr 2003)
diff --git a/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r1 b/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r1
new file mode 100644
index 000000000000..02794b6db342
--- /dev/null
+++ b/sys-cluster/openmosix-user/files/digest-openmosix-user-0.3-r1
@@ -0,0 +1 @@
+MD5 bc3b686cafe591a8207fc6c39c36ba6f openmosix-tools-0.3.tgz 143737
diff --git a/sys-cluster/openmosix-user/openmosix-user-0.3-r1.ebuild b/sys-cluster/openmosix-user/openmosix-user-0.3-r1.ebuild
new file mode 100644
index 000000000000..c7c1da54af90
--- /dev/null
+++ b/sys-cluster/openmosix-user/openmosix-user-0.3-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmosix-user/openmosix-user-0.3-r1.ebuild,v 1.1 2003/05/01 21:38:46 tantive Exp $
+
+S=${WORKDIR}/openmosix-tools-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openmosix-tools-${PV}.tgz"
+HOMEPAGE="http://www.openmosix.com/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.18"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ dev-lang/perl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+pkg_setup() {
+ if [ -z "`readlink /usr/src/linux|grep openmosix`" ]; then
+ eerror
+ eerror "Your linux kernel sources do not appear to be openmosix,"
+ eerror "please check your /usr/src/linux symlink."
+ eerror
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #make sure openmosix.config get's installed into /etc and not /etc/openmosix
+ mv Makefile Makefile.orig
+ sed -e 's:test -f $(SYSCONFDIR)/openmosix/openmosix.config:test -f $(SYSCONFDIR)/openmosix.config:' -e 's:.config $(SYSCONFDIR)/openmosix:.config $(SYSCONFDIR):' Makefile.orig >Makefile
+ rm Makefile.orig
+
+ cat > configuration << EOF
+
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\${OPENMOSIX}/include -I${S}/moslib ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install() {
+ dodir /bin
+ dodir /sbin
+ dodir /usr/share/doc
+ dodir /usr/share/man/man1
+ make INSTALLDIR=${D}/usr \
+ MANDIR=${D}usr/share/man \
+ SYSCONFDIR=${D}/etc \
+ BINDIR=${D}/bin \
+ SBINDIR=${D}/sbin \
+ RCDIR=${D}/etc/init.d \
+ LIBDIR=${D}/usr/lib \
+ install
+
+ dodoc COPYING README
+ rm ${D}/etc/init.d/openmosix
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ rm ${D}/etc/openmosix.map
+ #Test if mosix.map is present, stub appropriate openmosix.map
+ #file
+ if test -e /etc/openmosix.map; then
+ einfo "Seems you already have a openmosix.map file, using it.";
+ elif test -e /etc/mosix.map; then
+ cp /etc/mosix.map ${WORKDIR}/openmosix.map;
+ doins ${WORKDIR}/openmosix.map;
+ else
+ doins ${FILESDIR}/openmosix.map;
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/openmosix.map or"
+ einfo " delete it to use autodiscovery and then type:"
+ einfo " # rc-update add openmosix default"
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.18-openmosix-1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.18)"
+ einfo
+}