summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-04-06 05:30:17 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-04-06 05:30:17 +0000
commit79bf297cdf6ce4c07e7119620a99cfa81fa0a92f (patch)
tree0a86432bd2d3b1e9230ab68bba70fb55c2a2a0a6 /sys-cluster
parentless grizzly (diff)
downloadgentoo-2-79bf297cdf6ce4c07e7119620a99cfa81fa0a92f.tar.gz
gentoo-2-79bf297cdf6ce4c07e7119620a99cfa81fa0a92f.tar.bz2
gentoo-2-79bf297cdf6ce4c07e7119620a99cfa81fa0a92f.zip
less grizzly
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/ChangeLog8
-rw-r--r--sys-cluster/swift/swift-1.10.0-r1.ebuild115
-rw-r--r--sys-cluster/swift/swift-1.13.0.ebuild (renamed from sys-cluster/swift/swift-1.11.0-r1.ebuild)8
-rw-r--r--sys-cluster/swift/swift-2013.1.9999.ebuild122
4 files changed, 11 insertions, 242 deletions
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
index 83ce2f3ba33f..9267954a1f5b 100644
--- a/sys-cluster/swift/ChangeLog
+++ b/sys-cluster/swift/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/swift
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.25 2014/02/20 21:04:11 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.26 2014/04/06 05:30:17 prometheanfire Exp $
+
+*swift-1.13.0 (06 Apr 2014)
+
+ 06 Apr 2014; Matthew Thode <prometheanfire@gentoo.org> +swift-1.13.0.ebuild,
+ -swift-1.10.0-r1.ebuild, -swift-1.11.0-r1.ebuild, -swift-2013.1.9999.ebuild:
+ less grizzly
*swift-1.12.0 (20 Feb 2014)
diff --git a/sys-cluster/swift/swift-1.10.0-r1.ebuild b/sys-cluster/swift/swift-1.10.0-r1.ebuild
deleted file mode 100644
index 6e44a87e9042..000000000000
--- a/sys-cluster/swift/swift-1.10.0-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.10.0-r1.ebuild,v 1.1 2014/01/20 05:41:12 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils linux-info user
-
-DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-SRC_URI="http://launchpad.net/${PN}/havana/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="proxy account container object test +memcache"
-REQUIRED_USE="|| ( proxy account container object )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
- ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
- ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
- >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
- <dev-python/hacking-0.6[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
- >=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/dnspython-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- dev-python/python-swiftclient[${PYTHON_USEDEP}]
- memcache? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-PATCHES=( "${FILESDIR}/CVE-2014-0006-havana.diff" )
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
- sed -i 's/xattr/pyxattr/g' "${S}/requirements.txt"
- distutils-r1_python_prepare_all
-}
-
-src_test () {
- # https://bugs.launchpad.net/swift/+bug/1249727
- find . \( -name test_wsgi.py -o -name test_locale.py \) -delete || die
- SKIP_PIP_INSTALL=1 PBR_VERSION=0.5.23 sh .unittests || die
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
- newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
diff --git a/sys-cluster/swift/swift-1.11.0-r1.ebuild b/sys-cluster/swift/swift-1.13.0.ebuild
index b2bc8d26c74c..50ef0378a9a4 100644
--- a/sys-cluster/swift/swift-1.11.0-r1.ebuild
+++ b/sys-cluster/swift/swift-1.13.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.11.0-r1.ebuild,v 1.1 2014/01/20 05:41:12 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.13.0.ebuild,v 1.1 2014/04/06 05:30:17 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -30,9 +30,9 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/nosexcover[${PYTHON_USEDEP}]
dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
>=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )"
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/dnspython-1.9.4[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
@@ -49,7 +49,7 @@ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
~ZFS"
-PATCHES=( "${FILESDIR}/CVE-2014-0006-master.diff" )
+#PATCHES=( "${FILESDIR}/CVE-2014-0006-master.diff" )
pkg_setup() {
enewuser swift
diff --git a/sys-cluster/swift/swift-2013.1.9999.ebuild b/sys-cluster/swift/swift-2013.1.9999.ebuild
deleted file mode 100644
index 81cc6e2776a4..000000000000
--- a/sys-cluster/swift/swift-2013.1.9999.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-2013.1.9999.ebuild,v 1.4 2014/01/08 05:59:48 vapier Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils git-2 linux-info user
-
-DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-EGIT_REPO_URI="https://github.com/openstack/swift.git"
-EGIT_BRANCH="stable/grizzly"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="proxy account container object test +memcache"
-REQUIRED_USE="|| ( proxy account container object )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
- >=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )"
-
-RDEPEND="dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/netifaces[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/webob-1.0.8[${PYTHON_USEDEP}]
- <dev-python/webob-1.3[${PYTHON_USEDEP}]
- dev-python/python-swiftclient[${PYTHON_USEDEP}]
- memcache? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-src_test () {
- sh .unittests || die
-}
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
- sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
- newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
-
-#src_install()
-#{
-# distutils_src_install
-#
-# dodir "/var/run/swift"
-#
-# if use proxy-server; then
-# newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
-# fi
-#
-# if use storage-server; then
-# newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
-# newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
-# fi
-#}