summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-05-15 18:25:04 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-05-15 18:25:04 +0000
commitad2dd7ec336b2d95657b76bb267a58b6f0006d2a (patch)
tree323c1edd7c6c81fc2fa98567797b313744d257d7 /sys-cluster
parentCreate symlinks for texdoc. (diff)
downloadgentoo-2-ad2dd7ec336b2d95657b76bb267a58b6f0006d2a.tar.gz
gentoo-2-ad2dd7ec336b2d95657b76bb267a58b6f0006d2a.tar.bz2
gentoo-2-ad2dd7ec336b2d95657b76bb267a58b6f0006d2a.zip
adding udev scripts for bug 536500
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nova/ChangeLog6
-rw-r--r--sys-cluster/nova/metadata.xml5
-rw-r--r--sys-cluster/nova/nova-2015.1.0-r1.ebuild12
-rw-r--r--sys-cluster/nova/nova-2015.1.9999.ebuild14
4 files changed, 29 insertions, 8 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index 9bc9eb551285..127f27f9b60e 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.94 2015/05/15 07:30:26 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.95 2015/05/15 18:25:04 prometheanfire Exp $
+
+ 15 May 2015; Matthew Thode <prometheanfire@gentoo.org> metadata.xml,
+ nova-2015.1.0-r1.ebuild, nova-2015.1.9999.ebuild:
+ adding udev scripts for bug 536500
15 May 2015; Matthew Thode <prometheanfire@gentoo.org>
nova-2015.1.0-r1.ebuild, nova-2015.1.9999.ebuild:
diff --git a/sys-cluster/nova/metadata.xml b/sys-cluster/nova/metadata.xml
index a29a00994cca..e2f1f7bde0c8 100644
--- a/sys-cluster/nova/metadata.xml
+++ b/sys-cluster/nova/metadata.xml
@@ -12,12 +12,13 @@
</longdescription>
<use>
<flag name="compute">Installs the initscripts for the nova volume service</flag>
- <flag name="compute-only">only install stuff needed for a compute host</flag>
+ <flag name="compute-only">only install stuff needed for a compute host</flag>
+ <flag name="iscsi">Installs iscsi helper udev scripts</flag>
<flag name="kvm">qemu-kvm hypervisor support</flag>
<flag name="network">Installs the initscripts for the nova network service</flag>
<flag name="novncproxy">Installs the initscripts for the nova novncproxy service</flag>
<flag name="openvswitch">Installs openvswitch for the neutron openvswitch support</flag>
- <flag name="rabbitmq">Installs the rabbitmq server</flag>
+ <flag name="rabbitmq">Installs the rabbitmq server</flag>
<flag name="xen">xen hypervisor support</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/nova/nova-2015.1.0-r1.ebuild b/sys-cluster/nova/nova-2015.1.0-r1.ebuild
index f3dc79a4de45..7e75a50d47c5 100644
--- a/sys-cluster/nova/nova-2015.1.0-r1.ebuild
+++ b/sys-cluster/nova/nova-2015.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.0-r1.ebuild,v 1.3 2015/05/15 07:30:26 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.0-r1.ebuild,v 1.4 2015/05/15 18:25:04 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -14,7 +14,7 @@ SRC_URI="http://launchpad.net/${PN}/kilo/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen"
+IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
REQUIRED_USE="!compute-only? ( || ( mysql postgres sqlite ) )
compute-only? ( compute !novncproxy !rabbitmq !mysql !postgres !sqlite )
compute? ( ^^ ( kvm xen ) )"
@@ -184,4 +184,12 @@ python_install() {
insinto /etc/sudoers.d/
insopts -m 0600 -o root -g root
doins "${FILESDIR}/nova-sudoers"
+
+ if use iscsi ; then
+ # Install udev rules for handle iscsi disk with right links under /dev
+ udev_newrules "${FILESDIR}/openstack-scsi-disk.rules" 60-openstack-scsi-disk.rules
+
+ insinto /etc/nova/
+ doins "${FILESDIR}/scsi-openscsi-link.sh"
+ fi
}
diff --git a/sys-cluster/nova/nova-2015.1.9999.ebuild b/sys-cluster/nova/nova-2015.1.9999.ebuild
index 1327b8f89ce2..068cdb1ec057 100644
--- a/sys-cluster/nova/nova-2015.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2015.1.9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.8 2015/05/15 07:30:26 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.9 2015/05/15 18:25:04 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils git-2 linux-info multilib user
+inherit distutils-r1 eutils git-2 linux-info multilib udev user
DESCRIPTION="A cloud computing fabric controller (main part of an IaaS system) written in Python"
HOMEPAGE="https://launchpad.net/nova"
@@ -15,7 +15,7 @@ EGIT_BRANCH="stable/kilo"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen"
+IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
REQUIRED_USE="!compute-only? ( || ( mysql postgres sqlite ) )
compute-only? ( compute !novncproxy !rabbitmq !mysql !postgres !sqlite )
compute? ( ^^ ( kvm xen ) )"
@@ -185,4 +185,12 @@ python_install() {
insinto /etc/sudoers.d/
insopts -m 0600 -o root -g root
doins "${FILESDIR}/nova-sudoers"
+
+ if use iscsi ; then
+ # Install udev rules for handle iscsi disk with right links under /dev
+ udev_newrules "${FILESDIR}/openstack-scsi-disk.rules" 60-openstack-scsi-disk.rules
+
+ insinto /etc/nova/
+ doins "${FILESDIR}/scsi-openscsi-link.sh"
+ fi
}