summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-08-03 16:18:22 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-08-03 16:18:22 +0000
commitb57e65c49402a271d2b90c0e584479e46a597276 (patch)
treed4ea77524f637598c67f1c588fc6309543ba664d /sys-cluster
parentRemove older versions due to vulnerabilities. (diff)
downloadgentoo-2-b57e65c49402a271d2b90c0e584479e46a597276.tar.gz
gentoo-2-b57e65c49402a271d2b90c0e584479e46a597276.tar.bz2
gentoo-2-b57e65c49402a271d2b90c0e584479e46a597276.zip
add postgres support
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/csync2/ChangeLog5
-rw-r--r--sys-cluster/csync2/csync2-2.0.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/sys-cluster/csync2/ChangeLog b/sys-cluster/csync2/ChangeLog
index 38dbcbd65127..d4cdc13dcf61 100644
--- a/sys-cluster/csync2/ChangeLog
+++ b/sys-cluster/csync2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/csync2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.41 2015/08/03 14:03:34 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.42 2015/08/03 16:18:22 ultrabug Exp $
+
+ 03 Aug 2015; Ultrabug <ultrabug@gentoo.org> csync2-2.0.ebuild:
+ add postgres support and USE flag
03 Aug 2015; Ultrabug <ultrabug@gentoo.org> csync2-2.0.ebuild:
fix #556582, mysql build support
diff --git a/sys-cluster/csync2/csync2-2.0.ebuild b/sys-cluster/csync2/csync2-2.0.ebuild
index bd500e34e2ed..1eade62f0945 100644
--- a/sys-cluster/csync2/csync2-2.0.ebuild
+++ b/sys-cluster/csync2/csync2-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-2.0.ebuild,v 1.3 2015/08/03 14:03:34 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-2.0.ebuild,v 1.4 2015/08/03 16:18:22 ultrabug Exp $
EAPI=5
@@ -13,17 +13,18 @@ SRC_URI="http://oss.linbit.com/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
-IUSE="mysql sqlite ssl xinetd"
+IUSE="mysql postgres sqlite ssl xinetd"
RDEPEND=">=net-libs/librsync-0.9.5
mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )
sqlite? ( >=dev-db/sqlite-3.0 )
ssl? ( >=net-libs/gnutls-2.7.3 )
xinetd? ( sys-apps/xinetd )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="|| ( mysql sqlite )"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
SLOT="0"
src_configure() {
@@ -32,6 +33,7 @@ src_configure() {
--localstatedir=/var \
--sysconfdir=/etc/csync2 \
$(use_enable mysql) \
+ $(use_enable postgres) \
$(use_enable sqlite sqlite3) \
$(use_enable ssl gnutls)
}