summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-05-16 12:39:47 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-05-16 12:39:47 +0000
commitfbb504efad3be0acfc1b89dca24bf8b5b7993ad4 (patch)
tree78ed4f8ede7e5668578838531e93836b7236b0a7 /sys-cluster
parentmask samba[ldb] (diff)
downloadgentoo-2-fbb504efad3be0acfc1b89dca24bf8b5b7993ad4.tar.gz
gentoo-2-fbb504efad3be0acfc1b89dca24bf8b5b7993ad4.tar.bz2
gentoo-2-fbb504efad3be0acfc1b89dca24bf8b5b7993ad4.zip
Bump to corosync-2 branch
(Portage version: 2.1.10.59/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/corosync/ChangeLog8
-rw-r--r--sys-cluster/corosync/corosync-2.0.0.ebuild71
-rw-r--r--sys-cluster/corosync/files/corosync-2.0.0-docs.patch36
-rw-r--r--sys-cluster/corosync/files/corosync-2.0.0-rpath.patch33
4 files changed, 147 insertions, 1 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index 813e3ecfd58f..4eb00429575c 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/corosync
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.21 2012/05/16 09:39:24 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.22 2012/05/16 12:39:47 ultrabug Exp $
+
+*corosync-2.0.0 (16 May 2012)
+
+ 16 May 2012; Ultrabug <ultrabug@gentoo.org> +corosync-2.0.0.ebuild,
+ +files/corosync-2.0.0-docs.patch, +files/corosync-2.0.0-rpath.patch:
+ Bump to corosync-2 branch, ebuild masked in profiles/package.mask for testing
*corosync-1.4.3 (16 May 2012)
*corosync-1.3.5 (16 May 2012)
diff --git a/sys-cluster/corosync/corosync-2.0.0.ebuild b/sys-cluster/corosync/corosync-2.0.0.ebuild
new file mode 100644
index 000000000000..2cc94852e3e7
--- /dev/null
+++ b/sys-cluster/corosync/corosync-2.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-2.0.0.ebuild,v 1.1 2012/05/16 12:39:47 ultrabug Exp $
+
+EAPI=4
+
+inherit autotools base
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="ftp://ftp:${PN}.org@${PN}.org/downloads/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc infiniband static-libs"
+
+# TODO: support those new configure flags
+# --enable-watchdog : Watchdog support
+# --enable-augeas : Install the augeas lens for corosync.conf
+# --enable-snmp : SNMP protocol support
+# --enable-xmlconf : XML configuration support
+# --enable-systemd : Install systemd service files
+RDEPEND="!sys-cluster/heartbeat
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )
+ dev-libs/nss
+ sys-cluster/libqb"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.0-docs.patch"
+ "${FILESDIR}/${PN}-2.0.0-rpath.patch"
+)
+
+DOCS=( README.recovery SECURITY TODO AUTHORS )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable infiniband rdma)
+}
+
+src_compile() {
+ # Fix parallel compilation problem with libcmap
+ MAKEOPTS="-j1" base_src_compile
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+}
diff --git a/sys-cluster/corosync/files/corosync-2.0.0-docs.patch b/sys-cluster/corosync/files/corosync-2.0.0-docs.patch
new file mode 100644
index 000000000000..68de1f1b546d
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync-2.0.0-docs.patch
@@ -0,0 +1,36 @@
+Make docs optional
+
+--- configure.ac
++++ configure.ac
+@@ -432,7 +432,7 @@
+ fi
+
+ # final build of *FLAGS
+-CFLAGS="$ENV_CFLAGS $OPT_CFLAGS $GDB_FLAGS $OS_CFLAGS \
++CFLAGS="$ENV_CFLAGS $OS_CFLAGS \
+ $COVERAGE_CFLAGS $EXTRA_WARNINGS $WERROR_CFLAGS $NSS_CFLAGS"
+ CPPFLAGS="$ENV_CPPFLAGS $ANSI_CPPFLAGS $OS_CPPFLAGS"
+ LDFLAGS="$ENV_LDFLAGS $COVERAGE_LDFLAGS $OS_LDFLAGS"
+@@ -458,7 +458,10 @@
+ AC_SUBST([DARWIN_OPTS])
+ AC_SUBST([SOLARIS_OPTS])
+
+-AM_CONDITIONAL(BUILD_HTML_DOCS, test -n "${GROFF}")
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc],[Build html documentation])
++)
++AM_CONDITIONAL(BUILD_HTML_DOCS, [test -n "${GROFF}" && test "x$enable_doc" = "xyes"] )
+
+ AC_SUBST([LINT_FLAGS])
+
+--- Makefile.am
++++ Makefile.am
+@@ -46,8 +46,6 @@
+ config.guess config.sub missing install-sh \
+ autoheader automake autoconf test_lense.sh
+
+-dist_doc_DATA = LICENSE INSTALL README.recovery SECURITY TODO AUTHORS
+-
+ SUBDIRS = include common_lib lib exec tools test cts pkgconfig \
+ man init conf
+
diff --git a/sys-cluster/corosync/files/corosync-2.0.0-rpath.patch b/sys-cluster/corosync/files/corosync-2.0.0-rpath.patch
new file mode 100644
index 000000000000..4cca805066d8
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync-2.0.0-rpath.patch
@@ -0,0 +1,33 @@
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -49,7 +49,7 @@
+
+ EXTRA_DIST = $(bin_SCRIPTS) corosync-xmlproc.sh corosync-notifyd.sysconfig.example
+
+-COMMON_OPTS = -L../lib -L../common_lib -Wl,-rpath,../common_lib
++COMMON_OPTS = -L../lib -L../common_lib
+
+ corosync_cmapctl_LDFLAGS= $(COMMON_OPTS)
+ corosync_cmapctl_LDADD = -lcorosync_common -lcmap $(LIBQB_LIBS)
+@@ -57,10 +57,10 @@
+ corosync_fplay_LDADD = $(LIBQB_LIBS)
+
+ corosync_cfgtool_LDFLAGS= $(COMMON_OPTS)
+-corosync_cfgtool_LDADD = -lcfg $(LIBQB_LIBS)
++corosync_cfgtool_LDADD = -lcfg -lcorosync_common $(LIBQB_LIBS)
+
+ corosync_cpgtool_LDFLAGS= $(COMMON_OPTS)
+-corosync_cpgtool_LDADD = -lcfg -lcpg $(LIBQB_LIBS)
++corosync_cpgtool_LDADD = -lcfg -lcpg -lcorosync_common $(LIBQB_LIBS)
+
+ corosync_quorumtool_LDFLAGS = $(COMMON_OPTS)
+ corosync_quorumtool_LDADD = -lcmap -lcfg -lquorum -lcorosync_common \
+@@ -68,7 +68,7 @@
+
+ corosync_notifyd_CPPFLAGS = $(DBUS_CFLAGS)
+ corosync_notifyd_LDFLAGS = $(COMMON_OPTS)
+-corosync_notifyd_LDADD = -lcfg -lcmap \
++corosync_notifyd_LDADD = -lcfg -lcmap -lcorosync_common \
+ $(LIBQB_LIBS) $(DBUS_LIBS) $(SNMPLIBS) \
+ -lquorum
+