summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-21 23:43:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-21 23:43:04 +0000
commit8f5612486b6c2cb390de70c977b49d496e6f9217 (patch)
tree414d148815b9e3f5e4f443a9f8f08c965610b520 /sys-devel/bison
parentVersion bump. Also did some cleanup on the DEPEND/RDEPEND var's and added the... (diff)
downloadgentoo-2-8f5612486b6c2cb390de70c977b49d496e6f9217.tar.gz
gentoo-2-8f5612486b6c2cb390de70c977b49d496e6f9217.tar.bz2
gentoo-2-8f5612486b6c2cb390de70c977b49d496e6f9217.zip
Version bump #106803 by Michael Cramer.
(Portage version: 2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/ )
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.1.ebuild54
-rw-r--r--sys-devel/bison/files/digest-bison-2.11
3 files changed, 61 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 98dd1e7bb4f4..28a69a34891d 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.42 2005/09/15 04:26:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.43 2005/09/21 23:43:04 vapier Exp $
+
+*bison-2.1 (21 Sep 2005)
+
+ 21 Sep 2005; Mike Frysinger <vapier@gentoo.org> +bison-2.1.ebuild:
+ Version bump #106803 by Michael Cramer.
15 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+files/bison-2.0-token-name-translate.patch, bison-2.0.ebuild:
diff --git a/sys-devel/bison/bison-2.1.ebuild b/sys-devel/bison/bison-2.1.ebuild
new file mode 100644
index 000000000000..9067c30df7de
--- /dev/null
+++ b/sys-devel/bison/bison-2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.1.ebuild,v 1.1 2005/09/21 23:43:04 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic eutils gnuconfig
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+DEPEND="sys-devel/m4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.32-extfix.patch
+}
+
+src_compile() {
+ # Bug 29017 says that bison has compile-time issues with
+ # -march=k6* prior to 3.4CVS. Use -march=i586 instead
+ # (04 Feb 2004 agriffis)
+ if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
+ replace-cpu-flags k6 k6-1 k6-2 i586
+ fi
+
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib
+
+ dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}
diff --git a/sys-devel/bison/files/digest-bison-2.1 b/sys-devel/bison/files/digest-bison-2.1
new file mode 100644
index 000000000000..fd37b4ad3f14
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-2.1
@@ -0,0 +1 @@
+MD5 b1468d49c1357aebcd1de6ef12cbf3e8 bison-2.1.tar.gz 1316270