summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-23 02:57:46 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-23 02:57:46 +0000
commite756359ec1844a6d5c98211ee8d3aefe8e29ec3a (patch)
treef133618537cc2d83c9e3ab89dd2849dd3765f710 /sys-devel/bison
parentarm/s390/sh stable (diff)
downloadgentoo-2-e756359ec1844a6d5c98211ee8d3aefe8e29ec3a.tar.gz
gentoo-2-e756359ec1844a6d5c98211ee8d3aefe8e29ec3a.tar.bz2
gentoo-2-e756359ec1844a6d5c98211ee8d3aefe8e29ec3a.zip
old
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/bison-1.875.ebuild66
-rw-r--r--sys-devel/bison/bison-2.0.ebuild55
-rw-r--r--sys-devel/bison/bison-2.1.ebuild55
-rw-r--r--sys-devel/bison/bison-2.2.ebuild55
-rw-r--r--sys-devel/bison/files/bison-1.875-gccerror.patch50
-rw-r--r--sys-devel/bison/files/bison-2.0-token-name-translate.patch23
-rw-r--r--sys-devel/bison/files/digest-bison-1.8753
-rw-r--r--sys-devel/bison/files/digest-bison-2.03
-rw-r--r--sys-devel/bison/files/digest-bison-2.13
-rw-r--r--sys-devel/bison/files/digest-bison-2.23
10 files changed, 0 insertions, 316 deletions
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
deleted file mode 100644
index 8931ae7a635b..000000000000
--- a/sys-devel/bison/bison-1.875.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.30 2007/01/05 07:12:45 flameeyes Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="A yacc-compatible parser generator"
-HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
-SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls static"
-
-DEPEND="sys-devel/m4
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.32-extfix.patch
- epatch ${FILESDIR}/${PN}-1.875-gccerror.patch
-}
-
-src_compile() {
- # Bug 39842 says that bison segfaults when built on amd64 with
- # optimizations. This will probably be fixed in a future gcc
- # version, but for the moment just disable optimizations for that
- # arch (04 Feb 2004 agriffis)
- [ "$ARCH" == "amd64" ] && append-flags -O0
-
- # Bug 29017 says that bison has compile-time issues with
- # -march=k6* prior to 3.4CVS. Use -march=i586 instead
- # (04 Feb 2004 agriffis)
- #
- if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
- replace-cpu-flags k6 k6-1 k6-2 i586
- fi
-
- econf $(use_enable nls) || die
- use static && append-ldflags -static
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} \
- datadir=/usr/share \
- mandir=/usr/share/man \
- infodir=/usr/share/info \
- install || die
-
- # This one is installed by dev-util/yacc
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
-
- # We do not need this.
- rm -f ${D}/usr/lib/liby.a
-
- dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
-}
-
-pkg_postinst() {
- if [ ! -e "${ROOT}/usr/bin/yacc" ] ; then
- ln -s yacc.bison /usr/bin/yacc
- fi
-}
diff --git a/sys-devel/bison/bison-2.0.ebuild b/sys-devel/bison/bison-2.0.ebuild
deleted file mode 100644
index 71204e8b5731..000000000000
--- a/sys-devel/bison/bison-2.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.0.ebuild,v 1.4 2007/01/05 07:12:45 flameeyes Exp $
-
-inherit toolchain-funcs flag-o-matic eutils
-
-DESCRIPTION="A yacc-compatible parser generator"
-HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
-SRC_URI="mirror://gnu/bison/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls static"
-
-DEPEND="sys-devel/m4
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.32-extfix.patch
- epatch "${FILESDIR}"/${P}-token-name-translate.patch #106014
-}
-
-src_compile() {
- # Bug 29017 says that bison has compile-time issues with
- # -march=k6* prior to 3.4CVS. Use -march=i586 instead
- # (04 Feb 2004 agriffis)
- if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
- replace-cpu-flags k6 k6-1 k6-2 i586
- fi
-
- econf $(use_enable nls) || die
- use static && append-ldflags -static
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- # This one is installed by dev-util/yacc
- mv "${D}"/usr/bin/yacc{,.bison} || die
-
- # We do not need this.
- rm -r "${D}"/usr/lib
-
- dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
-}
-
-pkg_postinst() {
- if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
- ln -s yacc.bison "${ROOT}"/usr/bin/yacc
- fi
-}
diff --git a/sys-devel/bison/bison-2.1.ebuild b/sys-devel/bison/bison-2.1.ebuild
deleted file mode 100644
index 61ae19c72081..000000000000
--- a/sys-devel/bison/bison-2.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.1.ebuild,v 1.13 2007/01/05 07:12:45 flameeyes Exp $
-
-inherit toolchain-funcs flag-o-matic eutils
-
-DESCRIPTION="A yacc-compatible parser generator"
-HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
-SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls static"
-
-DEPEND="nls? ( sys-devel/gettext )"
-
-RDEPEND="sys-devel/m4"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.32-extfix.patch
-}
-
-src_compile() {
- # Bug 29017 says that bison has compile-time issues with
- # -march=k6* prior to 3.4CVS. Use -march=i586 instead
- # (04 Feb 2004 agriffis)
- if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
- replace-cpu-flags k6 k6-1 k6-2 i586
- fi
-
- use static && append-ldflags -static
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- # This one is installed by dev-util/yacc
- mv "${D}"/usr/bin/yacc{,.bison} || die
-
- # We do not need this.
- rm -r "${D}"/usr/lib
-
- dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
-}
-
-pkg_postinst() {
- if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
- ln -s yacc.bison "${ROOT}"/usr/bin/yacc
- fi
-}
diff --git a/sys-devel/bison/bison-2.2.ebuild b/sys-devel/bison/bison-2.2.ebuild
deleted file mode 100644
index 5dcb15bbacbb..000000000000
--- a/sys-devel/bison/bison-2.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.2.ebuild,v 1.13 2007/01/05 07:12:45 flameeyes Exp $
-
-inherit toolchain-funcs flag-o-matic eutils
-
-DESCRIPTION="A yacc-compatible parser generator"
-HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
-SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls static"
-
-DEPEND="nls? ( sys-devel/gettext )"
-
-RDEPEND="sys-devel/m4"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.32-extfix.patch
-}
-
-src_compile() {
- # Bug 29017 says that bison has compile-time issues with
- # -march=k6* prior to 3.4CVS. Use -march=i586 instead
- # (04 Feb 2004 agriffis)
- if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
- replace-cpu-flags k6 k6-1 k6-2 i586
- fi
-
- use static && append-ldflags -static
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- # This one is installed by dev-util/yacc
- mv "${D}"/usr/bin/yacc{,.bison} || die
-
- # We do not need this.
- rm -r "${D}"/usr/lib
-
- dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
-}
-
-pkg_postinst() {
- if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
- ln -s yacc.bison "${ROOT}"/usr/bin/yacc
- fi
-}
diff --git a/sys-devel/bison/files/bison-1.875-gccerror.patch b/sys-devel/bison/files/bison-1.875-gccerror.patch
deleted file mode 100644
index 65cfc03b1981..000000000000
--- a/sys-devel/bison/files/bison-1.875-gccerror.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- bison-1.875/data/yacc.c.gccerror 2002-12-28 09:36:02.000000000 +0100
-+++ bison-1.875/data/yacc.c 2003-06-24 18:05:35.000000000 +0200
-@@ -465,7 +465,15 @@
-
- #define YYACCEPT goto yyacceptlab
- #define YYABORT goto yyabortlab
--#define YYERROR goto yyerrlab1
-+#define YYERROR ]b4_location_if([do \
-+ { \
-+ yylerrsp = yylsp; \
-+ *++yylerrsp = yyloc; \
-+ goto yyerrlab1; \
-+ } \
-+ while (0)],
-+ [goto yyerrlab1])[
-+
-
- /* Like YYERROR except do call yyerror. This remains here temporarily
- to ease the transition to the new meaning of YYERROR, for GCC.
-@@ -1103,29 +1111,13 @@
-
- /* Else will try to reuse lookahead token after shifting the error
- token. */
-- goto yyerrlab2;
-+ goto yyerrlab1;
-
-
- /*----------------------------------------------------.
- | yyerrlab1 -- error raised explicitly by an action. |
- `----------------------------------------------------*/
- yyerrlab1:
--
-- /* Suppress GCC warning that yyerrlab1 is unused when no action
-- invokes YYERROR. */
--#if defined (__GNUC_MINOR__) && 2093 <= (__GNUC__ * 1000 + __GNUC_MINOR__)
-- __attribute__ ((__unused__))
--#endif
--
--]b4_location_if([ yylerrsp = yylsp;
-- *++yylerrsp = yyloc;])[
-- goto yyerrlab2;
--
--
--/*---------------------------------------------------------------.
--| yyerrlab2 -- pop states until the error token can be shifted. |
--`---------------------------------------------------------------*/
--yyerrlab2:
- yyerrstatus = 3; /* Each real token shifted decrements this. */
-
- for (;;)
diff --git a/sys-devel/bison/files/bison-2.0-token-name-translate.patch b/sys-devel/bison/files/bison-2.0-token-name-translate.patch
deleted file mode 100644
index ec00e0dccdb2..000000000000
--- a/sys-devel/bison/files/bison-2.0-token-name-translate.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-revision 1.57
-date: 2005/07/25 03:38:41; author: eggert; state: Exp; lines: +1 -1
-Fix core dump reported by Pablo De Napoli in
-<http://lists.gnu.org/archive/html/bug-bison/2005-07/msg00053.html>.
-* tests/regression.at (Invalid inputs with {}): New test.
-* src/parse-gram.y (token_name): Translate type before using
-it as an index.
-
-Index: src/parse-gram.y
-===================================================================
-RCS file: /cvsroot/bison/bison/src/parse-gram.y,v
-retrieving revision 1.56
-retrieving revision 1.57
-diff -u -p -r1.56 -r1.57
---- src/parse-gram.c 24 Jul 2005 07:24:22 -0000 1.56
-+++ src/parse-gram.c 25 Jul 2005 03:38:41 -0000 1.57
-@@ -538,5 +538,5 @@ gram_error (location const *loc, char co
- char const *
- token_name (int type)
- {
-- return yytname[type];
-+ return yytname[YYTRANSLATE (type)];
- }
diff --git a/sys-devel/bison/files/digest-bison-1.875 b/sys-devel/bison/files/digest-bison-1.875
deleted file mode 100644
index 59cccfecc71b..000000000000
--- a/sys-devel/bison/files/digest-bison-1.875
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b7f8027b249ebd4dd0cc948943a71af0 bison-1.875.tar.bz2 814922
-RMD160 8debeaf4e910a0e7f9887c419a57ee78599db31a bison-1.875.tar.bz2 814922
-SHA256 ffe3a491d96daf7c9bad3e999a7470442519a35b129f8a6e30597cbab8146db4 bison-1.875.tar.bz2 814922
diff --git a/sys-devel/bison/files/digest-bison-2.0 b/sys-devel/bison/files/digest-bison-2.0
deleted file mode 100644
index 73e4c18cb552..000000000000
--- a/sys-devel/bison/files/digest-bison-2.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c17f964fd5504b88b07a183420de25e3 bison-2.0.tar.gz 1163590
-RMD160 5ce9378e902194918dce4de04e096522f79144a8 bison-2.0.tar.gz 1163590
-SHA256 31b816846903d319a6f6cd1c9aada5ff83914206cb7df69c235ae909785109a1 bison-2.0.tar.gz 1163590
diff --git a/sys-devel/bison/files/digest-bison-2.1 b/sys-devel/bison/files/digest-bison-2.1
deleted file mode 100644
index 894a55d2542e..000000000000
--- a/sys-devel/bison/files/digest-bison-2.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ef3110077462b1140b2ae612626e8486 bison-2.1.tar.bz2 1005925
-RMD160 43967931eb04635547277bbd0152b45414420299 bison-2.1.tar.bz2 1005925
-SHA256 cb960197a77cfe8d36a969daa6eec577e22ca3d8fbae852b2cee5248bf6ae8ec bison-2.1.tar.bz2 1005925
diff --git a/sys-devel/bison/files/digest-bison-2.2 b/sys-devel/bison/files/digest-bison-2.2
deleted file mode 100644
index 5693609b32da..000000000000
--- a/sys-devel/bison/files/digest-bison-2.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e345a5d021db850f06ce49eba78af027 bison-2.2.tar.bz2 1077707
-RMD160 c31ff04eeebdfc3fe1bef860daeb7c979d9054af bison-2.2.tar.bz2 1077707
-SHA256 cb453a8b691ff3172ca470986da34d27bffac897347e6a5190b3938c8008ccb6 bison-2.2.tar.bz2 1077707