summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-24 12:13:40 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-24 12:13:40 +0000
commitdcce4424e555729a962572d6ffbea69c70e40091 (patch)
tree1464c9224356c2e5faa87e3df4567e917cb60940 /sys-devel/dragonegg
parentVersion bump to latest version. Thanks to Nikoli for the ebuild. Fixes bug #3... (diff)
downloadgentoo-2-dcce4424e555729a962572d6ffbea69c70e40091.tar.gz
gentoo-2-dcce4424e555729a962572d6ffbea69c70e40091.tar.bz2
gentoo-2-dcce4424e555729a962572d6ffbea69c70e40091.zip
Version bump, acked by voyageur. Update SRC_URI, add toolchain-funcs.eclass for tc-get*
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/dragonegg')
-rw-r--r--sys-devel/dragonegg/ChangeLog8
-rw-r--r--sys-devel/dragonegg/dragonegg-3.1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/sys-devel/dragonegg/ChangeLog b/sys-devel/dragonegg/ChangeLog
index 95fc7f58704f..425f50e5e3e2 100644
--- a/sys-devel/dragonegg/ChangeLog
+++ b/sys-devel/dragonegg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/dragonegg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.6 2012/01/27 02:47:00 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.7 2012/05/24 12:13:40 xarthisius Exp $
+
+*dragonegg-3.1 (24 May 2012)
+
+ 24 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +dragonegg-3.1.ebuild:
+ Version bump, acked by voyageur. Update SRC_URI, add toolchain-funcs.eclass
+ for tc-get*
27 Jan 2012; Christoph Junghans <ottxor@gentoo.org> dragonegg-3.0.ebuild:
keyword ~amd64-linux
diff --git a/sys-devel/dragonegg/dragonegg-3.1.ebuild b/sys-devel/dragonegg/dragonegg-3.1.ebuild
new file mode 100644
index 000000000000..8d6fb54e5a97
--- /dev/null
+++ b/sys-devel/dragonegg/dragonegg-3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.1.ebuild,v 1.1 2012/05/24 12:13:40 xarthisius Exp $
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="GCC plugin that uses LLVM for optimization and code generation"
+HOMEPAGE="http://dragonegg.llvm.org/"
+SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="|| ( sys-devel/gcc:4.5[lto]
+ >=sys-devel/gcc-4.6 )
+ ~sys-devel/llvm-${PV}"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_}.src
+
+src_prepare() {
+ # Replace svnversion call
+ sed -e "s/\(^REVISION:=\).*/\1${PV}/" \
+ -i Makefile || die "Setting revision failed"
+}
+
+src_compile() {
+ # GCC: compiler to use plugin with
+ emake CC="$(tc-getCC)" GCC="$(tc-getCC)" CXX="$(tc-getCXX)" VERBOSE=1
+}
+
+src_install() {
+ # Install plugin in llvm lib directory
+ exeinto /usr/$(get_libdir)/llvm
+ doexe dragonegg.so
+
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "To use dragonegg, run gcc as usual, with an extra command line argument:"
+ elog " -fplugin=/usr/$(get_libdir)/llvm/dragonegg.so"
+ elog "If you change the active gcc profile, or update gcc to a new version,"
+ elog "you will have to remerge this package to update the plugin"
+}